Support » Plugin: Twitter Widget Pro » widget doesn't show up on the page

Viewing 15 replies - 16 through 30 (of 37 total)
  • jmarteijn


    Tried to enter @ for the username and HTTP, but still no go!

    Any other suggestions?



    @FXfreelance How did you get it to work on you’re site?

    Plugin Author Aaron D. Campbell


    * Check your API usage by going into “WP Admin->Settings->Twitter Widget”. Make sure to check this a few times to see how much of your API limit is being used how fast (it resets every hour, so check if the limit is used in the first 5 minutes or if it lasts all hour)
    * Check to make sure the widget has been added to a sidebar in “WP Admin->Appearance->Widgets” and that the username is in @username form in it. Feel free to screenshot your settings and paste that here
    * You can try HTTP vs HTTPS in “WP Admin->Settings->Twitter Widget”
    * Also try to “Clear Update Locks” in “WP Admin->Settings->Twitter Widget”

    Let me know how that goes and be sure to paste screenshot of the widget settings from “WP Admin->Appearance->Widgets”



    * API usage stays constantly the same as below:

    Current API Usage Used: 150
    Remaining: 0

    * see screenshot of the widget settings


    Still no Widget appears!!


    Plugin Author Aaron D. Campbell


    jmarteijn: Your problem is that the widget can’t talk to Twitter because you’ve hit your limit. The limit is 150 requests per hour, and while the widget only uses 20 per hour (one every 5 minutes), the number used is calculated based on IP so every request from your shared server (or possibly cluster of servers) is counting against that total.

    The only solutions are to ask your host to move you to a different server with fewer Twitter requests being sent (sometimes they’ll do this, often they won’t) or use a widget that does authentication (and log it into your Twitter account). I don’t currently know of any WordPress Twitter widgets that do that. This one will eventually (I have to by March or it will stop working due to Twitter’s API changes), but I don’t know when exactly.



    My twitter widget is not showing up. I find that if i disable W3 total cache it shows up but as soon as i activate W3TC it disappears. This leads me to think there is some conflict between the two plugins. If it is not a conflict between the plugin is there a setting that I need to change in W3 Total Cache to get them to play nicely. Again, when I activate W3TC the widget disappears / does not display. When I disable W3TC it works fine. Any information would help. Thank you.

    Plugin Author Aaron D. Campbell


    elwingfield: Completely unrelated. Please don’t hijack this thread, I already answered in the thread you started.

    There must be something terribly wrong 🙂
    – fresh install (decided to give it a try to replace the old one)
    – no widget appear anywhere, no matter where I put it
    – API usage 6/150
    – cache cleared
    – switched to http
    Nothing helped. Oh well, back to my old fella then!
    Good luck with solving the issue 🙂

    Nothing shows up even in source code.

    working fine after changing to http

    Did all the things suggested, still no widget visible.

    Edit: API usage 150. Is this collective for all the sites from my web host??? If yes, this widget will never show up 😛

    Plugin Author Aaron D. Campbell


    It’s the collective for any sites on your IP. Depending on your host that could be LOTS. Unfortunately, I can’t control the limit (that’s imposed by Twitter)

    Hi All,
    I was having these same problems, but I wasn’t hitting my limit. For me, I had my Twitter privacy settings box checked to “Protect my Tweets”. I unchecked this box, and the plugin started working. In case that’s anyone else’s problem, thought I’d pass it along – not a plugin issue.

    Hmm it´s strange. I installed the Plugin a few days ago and it work´s fine.
    Today i´ve got the Message “There´s no Tweets availible.”
    I switched from https to http and i added the “@” befor my username.
    Any ideas?

    Thx, Markus

    You can see the page with the Plugin under:

    Hi I’m having the same problem. I have done ALL OF THE THINGS the plugin author suggests, nowhere near the API limit, my tweets aren’t protected, I updated to latest version, there’s the @ before my screen name, HTTP rather than HTTPs, cleared the update locks,…still NO TWITTER WIDGET showing up. There’s got to be something else I can do. Please help! This worked so well before, and it’s only as of recently that it stopped. 🙁


    I have the same problem with the “no tweets available” message, though the widget itself does show up with the twitter username.

    I’m running version 2.4.1 and I made sure that ‘http’ is checked in the settings instead of ‘https.’ I cleared update locks, but “There were no locks to clear.” Also, when the API Usage Limits reset, it still doesn’t work. I even added ‘@’ in front to the username, but it still isn’t working.

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘widget doesn't show up on the page’ is closed to new replies.