Support » Plugin: Category Posts Widget » Widget does not update on page reload

  • Resolved DSPodgorski

    (@dspodgorski)


    I’m using this plugin to add 4 widgets to my homepage, to show random posts from different categories.

    But reloading the page shows the same 4 pages instead of picking 4 more random options from the featured categories.

    I believe that I need to exclude the widget from caching, but I can not find an option in the widget to do this.

    How can this be done?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Daniel Floeter

    (@kometschuh)

    Do you use the option in the Filter panel Sort By: Random?

    Which caching plugin do you use?
    Because there is no issue open with caching plugins and that Random option.

    Thank you for the response. Yes, I’m using the random sort option, and I use W3TC for caching.

    I have tried telling W3TC not to cache anything on the homepage, but that didn’t help. And sadly I’m not familiar enough with how plugins are made to customize fragment caching for the widgets.

    But I’m fairly certain it is related to caching, because the 4 posts the widgets are stuck displaying change to a different 4 every time I purge all caches.

    • This reply was modified 5 months, 3 weeks ago by DSPodgorski.
    Plugin Author Daniel Floeter

    (@kometschuh)

    You can exclude the front page.
    That is an option from W3TC plugin.

    But please ask and edit your used caching plugin editor how to not cache some that.

    I think you may have misunderstood my previous message. I did already successfully exclude the front page from caching via W3TC. That did not solve the issue, because that exclusion did not apply to this widget.

    Plugin Author Daniel Floeter

    (@kometschuh)

    For my it works, if I exclude the front page … but after reset all the W3TC options.

    Is it possible for you to clean up your W3TC options and try to exclude than just the front page with reseted options.

    Delete that W3TC config folder to reset the options:
    [your-WP-installation]/wp-content/w3tc-config
    I read it here https://www.webnots.com/how-to-completely-delete-w3-total-cache-plugin/

    Unfortunately, that did not work either. No combination of settings in W3TC allowed the widget to update on reload.

    I also tried to switch to Litespeed Cache and disable PHP caching, but that also failed to work.

    But what DID work is switching to WP Super Cache, and disabling caching of the front page through that plugin’s default setting for that purpose.

    • This reply was modified 5 months, 3 weeks ago by DSPodgorski.
    • This reply was modified 5 months, 3 weeks ago by DSPodgorski.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.