Support » Plugin: All-in-One Event Calendar » Widget do not use GZIP

  • Resolved Piani

    (@webbmasterpianise)


    I use the calendar and its easy to use and have many features.

    One is the widget that I can easy use in the side bar.

    I have a little problem with this. The code is not included in the GZIP compression and I get warnings on performance and the site gets slower.

    This is the object that is not working with normal GZIP functions:

    
    ?ai1ec_render_js=common_frontend&is_backend=false&ver=2.5.28
    

    I have removed the widget now and all works normal. Any tip to get the widget to work wth GZIP compression?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sunny Lal

    (@sunny454)

    Hi @webbmasterpianise,

    Be sure that if you have Gzip compression turned on in the Settings of your calendar, that your server has it turned off. If your server is running Gzip compression, it should be turned off in your calendar. It should work fine. If it doesn’t, this error is most likely a result of a plugin or theme conflict (usually caused by a caching or security plugin).. Please try a different theme temporarily such as Twenty Seventeen, or, disable all plugins and then check if the problem recurrs — then re-enable each one until you find which one caused the problem. Let me know the results.

    Piani

    (@webbmasterpianise)

    Thanks for pointing me in the right direction. As a fast test I activated the widget again and then activated Time.lys own GZIP function in settings.

    The result was that the warnings dissapered from GTMetrix test but the site got much slower to load for some reason.

    As the initial error dissapeared the issue can be closed. I will investigate more what is causing this slower site and play around with my GZIP settings more. Today i have them in my .htaccess file.

    But for now I am fine with not using the widget and will look more on this after the hollidays.

    Merry Christmas 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Widget do not use GZIP’ is closed to new replies.