WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Widget displays thumbnails vertically, no spacing.

[Resolved] Widget displays thumbnails vertically, no spacing.

  • I’ve tried downgrading to 1.9 after using 2.x, with the same results.

    I’m using WordPress 3.6, latest PHP and latest NextGen build.

    I fixed the non-uploading issue by changing permalink structure, as suggested on this board.

    When I use the NextGen Gallery widget with default settings, all of the thumbnails displayed are stacked on top of each other with no spacing. This widget used to be perfect.

    I would consider purchasing professional support, but to be honest I’ve experienced nothing but trouble since the 2.x update.

    Any idea how to fix the widget?

    http://wordpress.org/plugins/nextgen-gallery/

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have the same problem I really hope they fix it soon!

    Okay so I think I found the solution.
    Every widgets that you use gets a individual ID or a tag…

    In my case it looks something like this:
    /*

    <img width=”150″ src=”http://www.xxx.com/wp-content/gallery/xxx/thumbs/thumbs_xxx.jpg” alt=”4488-xxx” title=”4488-xxx”>
    */
    Now find yours…

    So what I did was to Create a CSS for it,
    It looks like this:
    /*
    a.shutterset_xxxxxxxxxxxxxxxxxxxx {
    margin: 4px;
    padding: 1px;
    line-height: 1px;
    word-wrap: normal;
    top: 0px !important;
    float: none;
    display: inline-block;
    clear: none;
    position: relative;
    border-color: white;
    border-width: 3px;
    border-style: solid;
    background-color: #4c4c4c;
    }
    */
    Feel free to use my code.

    Now you need to find the main CSS file for your WP themes and insert the code into it, somewhere at the bottom works just fine.
    Remember to replace the xxxx to whatever is in your code…

    I know this is not a very good description of what to do but if you know CSS I’m guessing you’ll have no problem understanding what I’m trying to say…

    Good luck and if it works for you please mark this thread as Resolved.
    PS sorry for the bad formatting…

    Plugin Author photocrati

    @photocrati

    @bdungey – Do you have a caching plugin installed? You might try temporarily removing the caching plugin to fully clear site cache (delete under plugins tab – you can reinstall later) > clear browser cache and reload your site. Does that help?

    We have mentioned a fix for known widget issues in this thread: http://wordpress.org/support/topic/bug-report-nextgen-widget-not-working?replies=18 . This fix will likely resolve what you’re seeing here, but it might also be a caching issue you’re seeing. The fix will be included in v2.0.13 Beta & next update scheduled for Monday. I am going to mark this thread as resolved. If after upgrading to v2.0.13 / update on Monday the issue persists we can re-open this thread.

    @otechwebmaster – thank you for sharing your workaround 🙂 For you & others, we have included a update-proof CSS file to edit as of v2.0.7 + located under /wp-content/ngg_styles/nggallery.css . You can update / edit the CSS file under Gallery >> Other Options > Styles on your WordPress dashboard.

    -Becky

    I’m afraid that did not fix the problem…

    I did figure out a little workaround for the time being.

    I just used a shortcode in a text widget. Good enough.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Widget displays thumbnails vertically, no spacing.’ is closed to new replies.