Cat + Tag Filter
Widget breaks category taxonomy page (4 posts)

  1. cmccarra
    Posted 3 years ago #

    Hi, I'm implementing the widget like this on a portfolio page page:

    <?php the_widget('cat_tag_filter','title=Filter Stoves:&button_title=Filter&cat_list_label=By manufacturer:&category_tax=portfolio_cats&all_cats_text=All Manufacturers&tag_list_label=Of type:&all_tags_text=Any Type'); ?>

    I am using this widget on a portfolio page to limit posts by category, once the user has selected a category they are taken to that category page but the posts don't load as I'm also loading the widget on that page. It works fine when the widget is removed from the category page. Any suggestions on what could be causing this conflict?

    Edit: The posts load if I just have:

    <?php the_widget('cat_tag_filter'); ?>

    On the category page, so it seems its just the $args that are causing the problem. Any suggestions?



  2. ajayver
    Plugin Author

    Posted 3 years ago #


    Try to delete arguments one by one, to understand which one of them is causing a problem. Thanks!

  3. cmccarra
    Posted 3 years ago #

    Hi, Sorry for the late reply. It is the "category_tax=portfolio_cats" tag that is causing it, any ideas why?


  4. ajayver
    Plugin Author

    Posted 3 years ago #

    Hm... Not sure... Do you use a widget before or after the loop?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Cat + Tag Filter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic