• Resolved michelmannheim


    I just have the following issue :

    • The widget is on a page called calendar, the main menu drive to it, it’s fine
    • clicking on “find out more” the detailed event appears, it’s also fine
    • If now I want to go back, the “events” page appears instead of the “calendar” page!

    Thanks in advance for your help in solving this issue.
    What can I do ?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Jyoti Bhandari


    Hi @michelmannheim,

    Thanks for using our plugin and reaching out to us.
    Our plugin is just used to show events in different layouts. A single page is coming from the events calendar plugin this is not our plugin. In case if you want to design a single event page or change the All Events page link you can use our another plugin
    Event Single Page Templates Addon For The Events Calendar
    Let me know if you are still facing any issue.

    Thanks & Regards

    Thread Starter michelmannheim


    Thanks for your answer.
    I will try and keep you informed.



    I have faced the same problem. Go to Events Settings->Display and scroll down to Advanced Settings. In the ‘Add HTML before content’ add a button
    <input id=”btn_back” style=”border: none;” type=”button” value=”Go Back” />
    You can’t add javascript onclick event in here because it will just strip it out.
    You need to add the following script in the <head> section of the page (I use Elementor Pro and its Custom Code feature but there are other plugins that will let you do this easily.)
    <script type=”text/javascript”>
    jQuery(document).ready(function() {
    jQuery(‘#btn_back’).on(‘click’, function() {
    return false;

    That works a treat. When you go to the event it will return to the previous page NOT the awful events page. I’ve got the event widget on several pages with different filter so does the job well.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Widget’ is closed to new replies.