Support » Plugins » Why won’t any Lightboxesqe plugin load in my single posts?

  • I simply cannot figure out why I can’t get Lightbox-like (Thickbox, Slimbox, Shutter Reloaded) to work on my website. They all work easily everywhere on my site…except for single pages.

    More details and addresses in following post.

Viewing 6 replies - 1 through 6 (of 6 total)
  • For example, on the frontpage, I have a post about spore with images:

    Ok..images seem to popup fine. Now, what about the single post:

    Nope. Don’t work. I know its the template, but I can’t seem to find where it might be! I’ve used diff editors to compare, I’ve searched for alike CSS DIVs or errors…and I just cannot find anything.

    Is there some eagle-eyed person out there that can assist me with this problem? I just want to have the plugins work.

    Arg! This is very frustrating. The solution seems so simple – but I just cannot find it.

    I think I narrowed it down to the comments template on the theme that I’m using – but I still can’t find the problem.

    It seems when I remove the line:
    <?php comments_template(); ?> then it works. However, comments.php in the theme that I’m using is exactly the same as the one that’s included in the Default WP theme…which actually works with the Shutterbox plugin that I’m trying to get to work.

    I’m seriously ripping my hair out over this.

    Prototype and JQuery conflict!!! You are probably getting lucky on the home page, but then WordPress is having issues the further you go into your site. Basically…

    I would suggest using a lightbox plugin that doesn’t require JQuery and going with the Prototype library persoanlly, as you can use other tools such as Scriptaculous.

    If you really have to use JQuery, then there are lightbox plugins that run with that too…

    Are you positive that’s the problem? I’ve tried replacing it with numerous other plugins and the only one that seems to work is the Thumbnail Viewer plugin.
    I’ve tried Lightbox, Litebox, Thickbox, Slimbox, Shutter Reloaded, etc…all the different ones I could find – none of them work on the single page.

    But, if I change the theme to any other one (except another one called Illacrimo, which also doesn’t work) the plugins start working. But the page is still loading the same javascript – right? So why would that be a conflict.

    I just can’t see why I’m having so much trouble with this. Isn’t there some kind of plugin or system to prevent conflicts like this? Or is this really a different issue (as I think it might be)?

    More info: The template I’m using is based off of the Quickmint Rightnav template. That also doesn’t work on default…but I don’t know why. This is why I think its a template issue. What would it be in a template that wouldn’t allow scripts like this to work?

    Well, would anyone have any recommendations for some web-design forums or chats where I might be able to get some help on this? It just seems to be such a simple issue and I would really like to resolve it. Its just really beyond my capabilities.

    Still nothing? I was hoping after a month there would be a simple fix to this.
    I guess this is the last time I’ll bump this before I give up. I was thinking about just writing it from scratch, but that’s annoying when its an issue that seems as simple as this.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Why won’t any Lightboxesqe plugin load in my single posts?’ is closed to new replies.