WordPress.org

Support

Support » Plugins and Hacks » Comprehensive Google Map Plugin » Why my map suddenly shows only a gray square after a recent update?

Why my map suddenly shows only a gray square after a recent update?

  • Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Most probably the issue is related to jQuery version incompatibility:

    As of version 8.0.3, The CGMP plugin requires at least jQuery 1.9, as this is what more and more people use these days moving forward. In addition, starting from WordPress 3.6, it ships with jQuery 1.9.1.

    Some of you using the latest WordPress (at the time of writing this post it is 3.7.1), but still have an outdated jQuery, you may ask why? Well, some theme and 3rd party plugin developers ship their products with older versions of jQuery that disable loading of default jQuery (1.9+) shipped with WordPress these days.

    I suggest for you to fallback to plugin version 8.0.2 (compatible with jQuery pre-1.9:) if you cannot (or do not want upgrade jQuery) on your blog.

    http://downloads.wordpress.org/plugin/comprehensive-google-map-plugin.8.0.2.zip

    http://wordpress.org/plugins/comprehensive-google-map-plugin/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Sweet this solved my problem. Alexander you rock.

    Good luck with your move to the US.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Thanks 🙂

    Actually, if you have an older jQuery and jQuery Migrate plugin (http://blog.jquery.com/2013/05/08/jquery-migrate-1-2-1-released/) it should work too

    I love your plugin but I’m having a similar problem specific to the “Events Made Easy” plug-in. On the site’s regular pages, Comprehensive Google Map works fine, but on the events pages created in the “Events Made Easy” plugin, I get a solid green screen. It used to work fine. Now it doesn’t.

    Here’s the system info as reported on the CGM support page.

    Environment
    PHP v5.2.17
    MySQL v5.5.35-log

    WordPress
    WordPress v3.8
    Comprehensive Google Map Plugin v9.0.19
    Theme: Weaver II, v2.1.2
    Published posts: 0
    Published pages: 48
    Published nav_menu_items: 20

    JavaScript
    jQuery v1.10.2
    jQuery Core v1.10.2
    jQuery UI Core v1.10.3
    jQuery Migrate v1.2.1

    I make no claim to any programming prowess, so please respond in simple terms what I need to look for and/or do.

    Thanks for your help and especially for your plugin…I love it.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Can you please provide a link to the page/post where the map is?

    Thanks for your prompt response. Actually I can’t provide a good link right now and I don’t want to waste your time. After sending my initial message I tried a variety of changes…different event calendar plug-ins…even tried a different map plug-in. At some point in the process of doing that, I eliminated the database where the original events were stored. I am going to start over with a new event plug-in and will get back to you then if I still have the same problem.
    Thanks again.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Please do, and please provide a link to a page with map. I am sure we can get this working.

    Cheers

    Okay. Everything is rebuilt and I still have the same condition. If you will go to http://www.fcr-mm.org/event-list/ and then click on any of the events you will see what I am talking about.

    The crazy part is when I am creating the event, the maps show up on the editing page. However, once I publish it and it is added to the list of events, it presents the “green screen” map. If I go back into the edit mode, it’s still there.

    I am inclined to believe that the problem isn’t with your plug-in, but I would appreciate any help you can provide.

    Thanks!!!

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    I am not sure what happens when you publish your events, but what I can see is this by inspecting your page:

    1. Plugin’s JS scripts are not loaded
    2. That solid green screen is not generated by my plugin:
    <div id="eme-location-map_205_1389050178_06" class="eme-location-map"></div> – my plugin does not generate such HTML element
    3. On a non related issue, you have JS errors coming from other plugins:

    Uncaught TypeError: Cannot read property 'msie' of undefined jquery.tools.min.js?ver=3.8:1
    Uncaught TypeError: Object [object Object] has no method 'tooltip'

    I am quite sure that the problem is not my plugin, but how these event plugin/theme work… Unfortunately, if my plugin does not work for you in this case, maybe try another one? Have you tried Leaflet Maps Marker?

    Thanks. I appreciate your taking the time to look at it. Now I have to figure out how to get rid of these other JS errors. Thanks again.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Hi
    I’ve upgraded the lastest version of wordpress and Comprehensive Google Map Plugin and I’ve that gray square. So I downloaded and activated jQuery Migrate and jQuery updater but I’ve still the same pb… What should I do ?
    My website is : http://www.hypnoforme.fr
    Thanks in advance

    This happened already a few times before… be VERY Carefull when updating this plugin, it might just stop working (grey squares). Support apparently is then limited to ‘go update some other plugins’…

    Perhaps best to move away from this plugin

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    @djey-

    I can check in a day, I am away from my computer.

    @a2034487
    Its true, up to 2 months ago plugin was unstable. Now it is stable and compatible with jQuery 1.9+.

    In general, plugin can show gray screen sometimes due to even user configuration error. So not every time gray square is a plugins problem. Different plugins often have clashes with each other and clashes with different WP themes.

    WordPress Eco system is such that it gives a lot of freedom to developers to create stuff, and often this freedom creates a ground for clashes.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    @a2034487, also if you read this support forum more thoroughly (at least post from last two months), you will see that support is not limited just to “go update some other plugins” 🙂

    Thank you for your feedback nonetheless

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Ok…

    @djey-

    The active jQuery version on your site is 1.6.1. It is one of your plugins (or perhaps the theme itself) disabled jQuery shipped with your WordPress by default and instead an outdated jQuery was loaded from external CDN: https://ajax.googleapis.com/ajax/libs/jquery/1.6.1/jquery.min.js I will explain what it means for you.

    But before, I want to point something out: it is a an excellent practice to load JS resources from external CDNs (it can speed up page load time, etc.). But having said that, your website now is restricted to jQuery v1.6.1 only.

    A much more flexible and elegant solution here would be to check the jQuery version shipped with WordPress by default, and load THAT jQuery version from external CDN. Using the latter way, it would be ensured that the WordPress eco system uses the same version as the jQuery shipped with WordPress by default.

    Now, you are stuck with an outdated library that messes up behavior of plugins (like mine for example) that rely on jQuery shipped with WP by default, because some developer did not want to do extra work and conveniently loaded version that he needed.

    I do see that you have included jQuery migrate plugin, but it is not going to work in this case. Before I explain “why”, I want to note that I made a typo a couple of posts earlier when I spoke about jQuery Migrate plugin – the migrate plugin should be used when you have jQuery 1.9+:

    What jQuery Migrate plugin is ACTUALLY does: it prevents plugins and scripts that are using deprecated functions from breaking when you use jQuery 1.9+. In your case you are using jQuery 1.6.1, so the migrate plugin is of no help here.

    The solution I can offer you is:
    (a) make sure you are using jQuery 1.9+ by identifying what is loading the outdated jQuery.
    (b) If you cannot/do not want/not able to do (a), try using another Google Map plugin because I am not going to make my plugin compatible with jQuery version older than 1.9.

    I hope this helps and I apologize for inconvenience.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Why my map suddenly shows only a gray square after a recent update?’ is closed to new replies.
Skip to toolbar