Support » Fixing WordPress » Why isn't my plugin alerting that there is an update?

  • Resolved Evan Herman


    I just went in and re-checked in my plugin to the repository with tortoisSVN, and branch/tagged it and re-committed it.

    The original version is 1.0, the new version is 1.1.

    I tagged the main plugin php file as the new version, added the new stable tag to the readme file as well.

    I have two versions in my tags folder. A 1.0, and a 1.1.

    I have 1.0 installed on my site, and keep checking to see if it alerts me to update the plugin, but it doesn’t. Why is this happening? I’ve taken all the appropriate steps. What could I be doing wrong?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Ok I see a part of the issue.

    Why on my sepcific plugin page there is no Version number listed at all?? I have the version number declared (1.1) in the plugin PHP file, and had it declared as 1.0 in my original file.

    Why would it not show up on the plugin description page????

    Check two files in two places.

    In BOTH /trunk/ and /tags/1.1 make sure that the readme.php AND the main plugin.php file are updated. is NOT the same as however, and I think that’s what’s up here.

    that is most likely the issue. I didn’t even think that adding a v to the version number would cause that. Ill have a run through and change that and see if that helps at all. I will post back.

    Thanks Mika

    If it still doesn’t work, email plugins AT 🙂

    Ok I’ve changed file names to 1.0 and 1.1 instead of v1.0 and v1.1.

    I am waiting for the repository to re index, we will see…

    I’ve emailed them as the version number isn’t appearing on the button or anywhere on the plugin page. That must be the issue so I will post back when the issue is resolved to share how we resolved it.

    I thought it was something with my plugin header, but apparently it wasnt. I re-committed the plugin file with the correct header, but still no version number is showing up. So I’m still waiting on a response.

    meh, still nothing…..

    I’ve even compared my plugin files to that of a working one in the repository. Nothing is different. Sigh.

    I have never had such an issue with WordPress in all of my time using it….

    My first plugin and the repository can’t even recognize the version number? cmon man…..

    its right there in the header.



    Forum Moderator

    If it still doesn’t work, email plugins AT 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Why isn't my plugin alerting that there is an update?’ is closed to new replies.