Support » Plugin: Simple Social Share » WHY IS THIS NOT WORKING

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’ve got the same problem… The shortcode isn’t working.

    Plugin Author Perials

    (@perialscom)

    Hi RoFiks,

    Thanks for using this plugin.

    To use the shortcode make sure you have configured the below thing in the plugins setting page:

    1. At least one service is selected from ‘Select services’
    2. Either or both ‘Before Content’ or ‘After Content’ has been checked in ‘Select Position’
    3. Appropriate option is checked on ‘Show on’. For debugging you may check all the options i.e Home, Posts, Pages and Archives

    Let us know if this solves the issue.

    Hi Perials,

    Thanks for the help! I figured out it is working when I select one of the “Show on” options, but the media buttons are being displayed twice. I did hope the shortcode would work without having to select one of the “Show on” options (because I would like to add it manually on a custom post type page). I think it’s because this part of code:

    if( is_home() && !in_array( 'home', (array)$s3_options['ss-show-on'] ) )
     return '';
    if( is_single() && !in_array( 'posts', (array)$s3_options['ss-show-on'] ) )
     return '';
    if( is_page() && !in_array( 'pages', (array)$s3_options['ss-show-on'] ) )
     return '';
    if( is_archive() && !in_array( 'archive', (array)$s3_options['ss-show-on'] ) )
     return '';

    I found a workaround by selecting “Posts”, but removing the content filter:

    add_filter( 'the_content', array( $this, 'append_s3_html' ) );

    Is there another way to make the shortcode work by itself?

    Nothing. Not working for me. Really frustrating. 45 minutes I won’t get back in this lifetime.

    I added the [simple-social-share] code in the page in both text and visual mode. Tested draft posts, live posts.

    Did all of the suggested steps below after installing plugin, excepting “For debugging you may check all the options i.e Home, Posts, Pages and Archives” which is an absurd suggestion. Sounds a bit like add tape anywhere you think the box may fail in transit.

    “To use the shortcode make sure you have configured the below thing in the plugins setting page:

    At least one service is selected from ‘Select services’
    Either or both ‘Before Content’ or ‘After Content’ has been checked in ‘Select Position’
    Appropriate option is checked on ‘Show on’. For debugging you may check all the options i.e Home, Posts, Pages and Archives.”

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WHY IS THIS NOT WORKING’ is closed to new replies.