WordPress.org

Forums

why is this happening? (5 posts)

  1. Rok
    Member
    Posted 8 years ago #

    Whenever, I try to use the_excerpt function, it display's the post in excerpt mode, but doesn't display, link to continue anywhere in the post?

  2. moshu
    Member
    Posted 8 years ago #

    The excerpt does NOT have that feature. So, you are just seeing the normal behaviour of that template tag.

    The "more" thing is displayed when you use the_content + you manually inmsert the "more" tag in your text.

    Workaround: http://guff.szub.net/2005/02/26/the-excerpt-reloaded/

  3. Kafkaesqui

    Posted 8 years ago #

    the_excerpt() does not provide any sort of "continue reading" link automatically. For that one would typically use the_content() with the <!--more--> quicktag slipped into each post.

    More on that:

    http://codex.wordpress.org/Customizing_the_Read_More

    (20 seconds)

  4. Rok
    Member
    Posted 8 years ago #

    1. Ok, that means, regular the_excerpt() will show post in excerpt mode and to read the full post, one has to click Post title, is that right?

    2. I'm facing another very strange problem:

    a. earlier I was using content function, which I replaced with inline-ajax-front-page plugin.

    It works, but to display full post, it directly fetches the post from the DB and bypass other functionalities.

    Now, when I disable this plugin, and use regular excerpt function, the page doesn't load completely, i.e. it display only single post, and no sidebar etc.

    I've tried this by de-activating and remvoing, but the problem remain as same.

    Can anyone advice, I've written at plugin authors site also, but didn't received any reply.

  5. Tfleming
    Member
    Posted 8 years ago #

    I am using HemingwayEx theme, and am having a problem with the excerpt function... very small problem, but asthetically it throws off the reader.

    The problem is that there is no clear indication at the end of the excerpt. I would like to have an ellipse appear at the end of the last word in the excerpt, but can not figure where in the code I should be putting it. tried several places, with no success.

    Advice appreciated!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.