WordPress.org

Forums

Visualizer
[resolved] Why is there suddenly a problem viewing my chart? (4 posts)

  1. holostravy
    Member
    Posted 1 year ago #

    Hi,

    I've been using a google spreadsheet with my Visualizer plugin and I've never been able to get it to work directly from the 'publish to the web'/online csv file. However, it had been working fine with a downloaded file from my computer until this evening, when an error message suddenly appeared in my Visualizer media library page:

    "allow_url_fopen option is disabled in your php.ini config. Please, enable it by change its value to 1. This option increases the speed of remote CSV uploading."

    What does this mean? I can't seem to find a php.ini file. (Do you mean the config.php file?) My chart no longer appears on my site.

    If possible, I'd also love to know how to fix the issue with the "From the Web" option so that my chart could automatically update from the google spreadsheet, but more than anything I just want it to work.

    Let me know - thanks!

    https://wordpress.org/plugins/visualizer/

  2. madpixels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    "allow_url_fopen option is disabled in your php.ini config. Please, enable it by change its value to 1. This option increases the speed of remote CSV uploading." What does this mean?

    This message means that allow_url_fopen setting is disabled for your PHP by your hosting provider. That is why you haven't been able to use "From the Web" sources. To fix it you need to enable this option by changing it in the php.ini file (if you can do it), by changing settings in the hosting dashboard panel or by asking hosting provider to enable it for you.

    My chart no longer appears on my site.

    It is quite strange because it has to work. Could you please enable debugging on your site and logging by adding WP_DEBUG_LOG to your wp-config.php file? After enabling it, reproduce the issue with your chart and send me debug.log file which has to be located in wp-content folder. To properly enable debugging you need to have following commands in your wp-config.php file:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
  3. holostravy
    Member
    Posted 1 year ago #

    Hi there,

    Great! I fixed the host issue following your instruction and it finally works from the web - thanks so much for the prompt and clear reply. (Also, I figured out the chart appearance problem - it was my fault, I'd tried updating it with the wrong file.)

    Works great now - thanks!

  4. madpixels
    Member
    Plugin Author

    Posted 1 year ago #

    You are welcome! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Visualizer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic