WordPress.org

Forums

[resolved] Why is my WordPress Blog a blank page? (26 posts)

  1. PetLvr
    Member
    Posted 9 years ago #

    http://HART-Empire.com ... I have several blogs and I am not a newbie. I have two host servers. Everything on one server works. This and another blog, is on a different server - but the second one works!. This does not. My last post was Friday. I knew it existed Saturday morning. According to feedburner my feed stopped at 11:51am Saturday, and now it's a white screen. All the files are still there and the server is not down. My 404-Error file doesn't even click in, it just loads white space.

    Are there any suggestions or directions that I can go to get this up and running? Does this sound like a database problem? I'd hate to restore a backup - because quite frankly I don't trust what I've been backing up .. (EDIT: Not that I can load WordPress to restore it anyway) sometimes it works, sometimes it doesn't .. that' with both skippy.net and that other laughing lizard one. I know if I toss a non-blog related index.html or another index.php into my root directly - it will load.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Upload a new theme and switch to it ?
    I'm assuming you can get to the admin. White screens are commonly caused by a faulty theme, and if you did nothing it could be your host moving files around.

  3. PetLvr
    Member
    Posted 9 years ago #

    I can't even access anything inside the wordpress. However, I can see the files via FTP. I deleted my entire theme folder and copied in the default .. just to see ...

    [ (edit) Firstly: recopied all the /themes/subfolders/ and then secondly, copied the default files into my existing theme/northern-web-coders/ folder... ]

    Same difference - nothing loads up except a white screen. It's as if WordPress is gone.

  4. PetLvr
    Member
    Posted 9 years ago #

    btw - I have two host providers. Occassionally, I used to get an error message by WordPress something to the effect.. "ERROR ESTABLISHING A CONNECTION". I would send an email to my 1st provider and they 'restarted the database'.

    What does this mean? My second host provider that http://HART-Empire.com is on - doesn't get that error message, but when I as them to "restart the database" they go .. 'huh?' (live chat outsourcing) Is that something I can do manually here on my end?

  5. Basically, that means that the first host has an unstable database server which has froze or gone offline when you see the "ERROR ESTABLISHING A CONNECTION" message. A restart is the only way to bring the database server back online.

    The second host is probably confused by your restart request because their database server is functioning properly and there would be no reason for a restart.

    Server restarts can only be initiated by your hosting provider.

  6. tomhanna
    Member
    Posted 9 years ago #

    Try reuploading a fresh set of all the WordPress files. Don't install again, just upload new files in case any of the files were corrupted.

  7. PetLvr
    Member
    Posted 9 years ago #

    Macmanx - that was kind of funny, and you are right. But the first server - it did happen only 3 times since May 31, 2005 when I first started. Perhaps it is unstable? I dunno. Maybe that's why they knew how to fix it.

    As for the second host provider - it's still down since Saturday, it's monday night now. Their most recent email looked like this:

    Dear Valued Customer,
    Thank you for contacting Support.
    Your site is up and working the problem is the php script is not parsing with the server which we need to check. This issue is on queue with our tier 2.
    Please bear with us.

    I have asked them to just please a dissatisfied customer and initiate a reboot or restart to the database - but they won't because they can't believe it could be that simple as turning it off and on. It's aggravating.

    PS: tomhanna .. I have tried deleting the both all the template files in the \theme\ folders that I am using and also deleting all the \wp-admin and \wp-includes and the main root wordpress directory - to no avail.

  8. vkaryl
    Member
    Posted 9 years ago #

    Time to dump them and move to the "real" host, sounds like....

  9. PetLvr
    Member
    Posted 9 years ago #

    It's Globat.com with tons of space or bang for my buck. Everything else has been excellent (well speed anyway). Maybe I should just use it to store mp3's and backups and keep the blogs away from here. The worse part, for me, is the outsourced live chat- you have to wait for help, are in the middle of multi-tasking agent that can't help you but type tickets. Yes - dumping them is a consideration. This is unacceptable for one to host your blog.

    Who would you recommend?

  10. chanzero
    Member
    Posted 9 years ago #

    i can't believe this - i'm having the exact same problem! one minute i'm working on my wordpress site, next thing i'm getting blank white pages!

    i'm working on the WP stuff in a folder called /WP/ off the root. everything else works fine. i downloaded a new copy of WP and uploaded those files, got the "you don't have a wp-config.php file", etc - i changed my settings on that to work correctly, and once again blank white screens

    additionally, when i say the rest of the site is working, for example i have forums where the info is on the same database as WP and the forums work fine. i'm really confused -- and kind of scared! what should i do?

    i can ask for a server restart, but i'm not sure that's the problem since everything else is working fine?

    EDIT: i just checked my server status in cpanel and there was a red light by this one

    Server Load 3.94 (4 cpus)

    i have no clue what that means, but i figure a red light is bad and might possibly explain why i'm having probs. i can ask for a server restart but not sure why the rest of the site/databases are fine

    i'm also worried that WP might be putting a strain on the server? i have close to 6000 posts which i imagine is fine, though it will surely keep growing... for some reason i suspect if there is a strain it isn't the amount of records but perhaps a plugin?

    regardless, any input on all of this is deeply appreciated!!

  11. PetLvr
    Member
    Posted 9 years ago #

    aha! So I'm not crazy! That's what I noticed about mine too - the database is there. I have that second blog working but, with different prefixes. I probably only have about 20-30 posts though. I just started this one in mid-October - so, I don't think it would be the 'strain' factor.

    I just went into my database to try to see if I had any errors like your Server Load ... I noticed this:

    Error
    The additional Features for working with linked Tables have been deactivated. To find out why click here.

    When I click "here" I get another screen that says:
    Database xxxx running on localhost
    PMA Database ... not OK[ Documentation ]
    General relation features Disabled

    When I click on Documentation, I get this:

    http://www.hart-empire.com/globat/phpMyAdmin/Documentation.html#pmadb

  12. PetLvr
    Member
    Posted 9 years ago #

    Sorry to dump all my troubles on all of you, and all your help is GREATLY appreciated! Now - tech has given up claiming it's my fault and the PHP scripts "contain redundant newline characters. This usually indicates that they were transferred in binary mode." Naturally, I am quite aware of this with 8 blogs now, and I always upload in ASCII the .php files and the images in BINARY. Meanwhile, I have also re-copied over existing files, and also deleted files and copies original files from the download .zip file .. And it's still blank.

    So - I can't see or access wordpress.

    But - what if I were to create a new wordpress blog? I would basically start all over this way .. (a) Put the install.php file back in the /wp-admin/ folder, and (b) change database variables after creating a NEW database name .. eg instead of prefix WP_ I would create WP2_ ...

    So - Now I would have a new blog with new tables and database and it should work, right?

    Is there a way to get all the database entries of WP_ into WP2_ ? At least if it's all back - I can recover and make a backup of this properly, and find a new server and start from scratch.

  13. chanzero
    Member
    Posted 9 years ago #

    hey pet, maybe we're in this thing together lol --- and i've pretty much done what you're thinking

    i downloaded WP again and installed it again - this time, as you suggested, with a WP2_ prefix. lo & behold everything worked fine.

    then i went into PhpMyAdmin and made backup copies of the WP2 tables. then i started copying my WP tables over into WP2 (renaming them). i started with categories, posts, post2cat, postmeta & users. with all of these ported over, the site still worked.

    when i copied options over is when i got a blank page. so now i have to figure out what option is screwing my site up lol

    what i'd like to do i slowly "deactivate" these options via PhpMyAdmin until i figure out which one is the culprit -- unfortunately i don't know what the heck some of these fields mean or do... hopefully someone will see our struggles and shed some light (now that i have sorta narrowed things down?)

    alternatively i guess i'll just stick with the default options and add the plugins back in one at a time. as long as i have my post info i guess it'll work out ok :)

    good luck and let's keep each other updated!

  14. chanzero
    Member
    Posted 9 years ago #

    actually one other thought -- i'm thinking the culprit might be a plugin, but my current WP(2) has no plugins. i mean, physically the plugin folder just has the ones that WP ships with. although the ported-over options table still has the info for all of that, i would think if the actual plugin isn't there then it's not causing problems? hmm. again, some help would be awesome, but i'm going to keep banging away at this :)

  15. PetLvr
    Member
    Posted 9 years ago #

    Well - that is promising! I will create a new wordpress blog - and, maybe you can help me to copy the tables? Feel free to try me on MSN Messenger ... my id would be .. msn@PapillonLvr.com

  16. chanzero
    Member
    Posted 9 years ago #

    i found the problem! AJAX SPELL CHECKER! i have no idea why, but when i moved this one into the plugin folder i got the white screen of death again. but then as soon as i deleted it, it was fine!

    pet, if you have that one, try deleting it! (i tried to email you, don't know if you got it...)

  17. PetLvr
    Member
    Posted 9 years ago #

    Okay. I created a brand new blog as I suggested, with different prefix. It worked. I couldn't figure out how to import the exported tables individually into the new prefix tables. So, I contacted "live chat" and this is what was done. I created a SECOND MySql database with a different database name, with a different mysql username , and different Password. The 'support' guy used Mysql Client to dump the tables into a backup.sql file. There were 11 tables in all - (9 plus two _ss_search and _ss_stats tables - must be a plug in). Then, he imported them into this new database 2.

    I changed the variables in wp-config.php file for this new database and username and password.

    I try going to http://HART-Empire.com again and .. drats - I get the same problem - blank screen... This is view source..
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
    <BODY></BODY></HTML>

  18. chanzero
    Member
    Posted 9 years ago #

    hmm. so do you have the ajax spell checker plugin? it really has to be something like that which you need to take out. seeing how you don't have access to the sql end of things, i would ask your support guy to delete the current "wp_options" table (ported from your original WP) and ask him to put the other newer one (unaltered from setup) back -- pretty sure your site will work then. then you just have to redo all your plugins...

  19. PetLvr
    Member
    Posted 9 years ago #

    I have access to Myphpadmin and my database ... I believe the ss_stats is the shortstats option.

    I still am up fiddling with this. I tried 3 times now. with http://www.tamba2.org.uk/wordpress/restore/ podz restore guide. I've restored from both ends. I've tried to empty the shortstats .. If I were drinking coffee I'd pull my hair out.. soon it will be morning and I'll make a pot of coffee and probably be in same boat :( .. I wish someone helpful would be willing to look at it. I'm going nowhere.

    PS: I don't have the ajax spell checker .. in my plugin folder, there is tons of plugins, but not activated. I'm sure there are many that was activated ..

  20. PetLvr
    Member
    Posted 9 years ago #

    chanzero --- take a look at my site http://HART-Empire.com ... I AM UP! 100% Recovery! WooHoo!!

    I took your advice.

    First, in the 2nd/new database, I exported options table basically following the http://www.tamba2.org.uk/wordpress/backup/ instructions.

    Second, I exported options table in my dummy database/. It was the first attempt to create i.e. WP_2 tables with new installation.

    Third, in my 2nd/new database, I clicked on the database and ticked the options table and "empty"'ed it.

    Fourth - I loaded the backup_options.sql of the second option above, into notepad, and manually copied everything except the header into the field, overwriting some text that was there, and pressed GO.

    The page was blank still - but, it was orange or whatever the surrounding background of my page is. So, I went directly into /wp-admin/ and activated all my plugins.
    Then, I loaded up the options of my PetLvr.com/blog/ - because all options are set the same for me - and I set my options, and created the permalink structure.

    Then - it loaded! *whew* ..

    Obviously had some side effects - Pre-issue I had about 10 feedburner count. Now I've got 1 (me).. Oh well. Precautions for next time.

    Take care.

  21. chanzero
    Member
    Posted 9 years ago #

    although i don't quite get the cause of your problem, it's good to hear you're back up :)

  22. choleric
    Member
    Posted 9 years ago #

    wow. I just had this exact problem so I'm going post something here in case other people run to this.

    Basically I wasn't having issues with the plugin mentioned but this WAS caused by SOME plugin. I deleted every plugin in my folder and the site load up fine. Then I systematically added the ones that I still used one by one. I never really tracked down the faulty one, but since I didn't use it anymore I didnt really care.

    Thanks for the posts and updates guys.

  23. pvalente
    Member
    Posted 8 years ago #

    My wordpress blog is hosted with Dreamhost and I found this in their support wiki:

    If you have "blank pages" in WordPress with wp-cache turned on after you upgrage to PHP 5.1.2 - there is simple fix to solve the problem:-

    1. Open wp-cache-phase2.php file* in your favourite text editor
    2. Find out wp_cache_ob_end function
    3. then inside that function find out line with: ob_end_clean(); (it should be line 219 or about)
    4. and finally replace that line with: ob_end_flush();

    I had already turned off wp-cache, but this solved my problem of a blank screen on every first load.

  24. luchtzak
    Member
    Posted 8 years ago #

    Dear,

    I run WordPress version 2.2 latest one, php version is 4.2.2

    it isnworking anymore, I tried the fix mentioned in the last reply but I cant locate that particular file. Can somebody help me. Kind regards,

    Bart

  25. Dusty
    Member
    Posted 8 years ago #

    wp-cache-phase2.php is on your server in the folder wp-content / plugins / wp-cache. By the way, pvalente's instructions fixed the problem for me. Thanks!

  26. makebbekus
    Member
    Posted 8 years ago #

    Thank you everyone who contributed to this post. I had been agonizing over this (same problem with white screen) for the last few weeks, and pvalente's fix worked perfectly for me.

    Cheers,
    Michael

Topic Closed

This topic has been closed to new replies.

About this Topic