WordPress.org

Support

Support » How-To and Troubleshooting » Why is my comments closed in all posts – open in all pages…!??

Why is my comments closed in all posts – open in all pages…!??

  • conclusion:

    problem:
    Why is my comments closed in all posts – functions alright and is open in all pages…!??

    earlier discussion about this:
    http://wordpress.org/support/topic/comments-are-closed-i-cant-open-them-and-there-are-no-universal-settings?replies=16

    – Have Unactivated almost all my plugs, repaired the database.
    – When I change the theme the comment function is ok – so it might be themerelated…
    – Have compared and checked the comments.php and the functions.php
    (it seems to be ok agains the originals)
    – I have comments on in settings and in posts

    What could possibly be the fault here…?
    What is closing the comments on posts – but not on pages…?

    If there is any idea about the cause – and more importantly – the solution I would be very grateful.
    If there is someone who like to look at the code – we can do that.

    I have theme Forte
    blogaddress: http://mickansandelin.se/blog/

    Regards

    mike

Viewing 15 replies - 16 through 30 (of 44 total)
  • Same thing just happened to me!!

    “Users must be registered and logged in to comment “
    “An administrator must always approve the comment ”

    Were ALWAYS unchecked for me – I allow anyone to comment. And now are both checked. What could change our dashboard like this??

    Actually, the Discussion Module under each post is missing, as well. My other blogs are okay, so it’s not the server. And it’s not a theme, as no other theme works on this blog, either.

    I haven’t added any plugins. Help?

    rjhayton, I just reread all these and I have Ipower, too. But my other blogs are okay.

    My theme is Dansette and my blog is here, if this helps: http://opedcartoons.com/.

    I think it’s clear that it’s a WordPress problem, since the Discussion module that appears on your screen at the bottom of every Edit Post you write (next to Blog Author, Custom Fields, etc) is totally gone. I had to go into Screen Options to make it reappear.

    My concern is why or how did all these changes happen to comments/discussion without me doing it???

    Now I’m enabling comments one by one in each post – so annoying.

    Drawer, I feel your pain. 🙁 Hope someone addresses this. HELLO?????

    Posted how to bulk edit on my original post.

    Alison, thanks, that saved me some time! And my Discussion Settings appear to be stable – no more changes that I didn’t do!

    I just don’t understand why this is only affecting a couple of us…

    Updated original post with some info. I will probably only update on that thread. Never had such a serious, lasting, unaddressed bug before.

    I added an update to that post, too. I haven’t had recurring issues but I did experience this and I don’t know why.

    hiii
    i have had the same problem
    after too many trials i did what is said here
    it works well check this
    http://www.lancelhoff.com/enable-or-disable-comments-on-all-posts-in-one-step/

    all u need is to excecute 2 sql query in your database
    UPDATE posts p SET comment_status = ‘closed’, ping_status = ‘closed’ WHERE comment_status = ‘open’;

    and this
    UPDATE posts p SET comment_status = ‘open’, ping_status = ‘open’ WHERE comment_status = ‘closed’;

    read the link 4 more detailed info

    good luck :)))

    Sign me up for having this very same problem.

    And I have tried to track it down in every possible way to no avail.

    And I have I-Power.

    I’m using i-power too.

    I wonder if they’re not doing some machinations to everyone’s database when they mess with their version of WordPress?

    When I first installed WP, I used their tool in the control panel. Since then, I’ve done all the updates on my own since they are way behind on updating it on their own. Now I’m wondering if setting it up that way and updating it on my own is part of, if not, the problem?

    Not sure that I-Power is the problem, although I’ve had problems with them. People on a variety of servers and using a variety of plugins and themes have reported this problem.

    This plugin helps, it’s a simpler way of doing what yamama87 mentioned above. It also has an “auto” option to automatically keep comments on. It’s worked for me so far:

    http://wordpress.org/extend/plugins/extended-comment-options/

    I have never used I-Power — don’t even know what it is. And for the past many months I’ve upgraded within the control panel.

    Hope that info helps in weeding through the issues.

    Maybe the new version???

    Ipower is a host

    I want to find a better solution than a plugin that is just a “pain killer” for the actual problem.

    Same problem. IPower User, but I cannot believe that this is a host related issue. While I installed using the IPower installer, I upgraded to 3.1 from WordPress.

    hiii
    i have had the same problem
    after too many trials i did what is said here
    it works well check this
    http://www.lancelhoff.com/enable-or-disable-comments-on-all-posts-in-one-step/

    all u need is to excecute 2 sql query in your database
    UPDATE posts p SET comment_status = ‘closed’, ping_status = ‘closed’ WHERE comment_status = ‘open’;

    and this
    UPDATE posts p SET comment_status = ‘open’, ping_status = ‘open’ WHERE comment_status = ‘closed’;

    read the link 4 more detailed info

    good luck :)))

    This worked perfectly for me – thanks guys! )

Viewing 15 replies - 16 through 30 (of 44 total)
  • The topic ‘Why is my comments closed in all posts – open in all pages…!??’ is closed to new replies.
Skip to toolbar