Support » Localhost Installs » Why I am getting error after setting permalink to Pagename?

  • Resolved deep4project

    (@deep4project)


    Hi frnds,

    I am using wordpress for website at localhost as well as for my website. There is not post anywhere in my website or localhost. For the pages, I changed my permalinks to /%pagename%, but I am getting error “The requested URL not found on this server. I also tried /%postname%/ , but same error. I also tried ideas from many forums, but there is not sure solution anywhere.

    Please don’t refer page “http://codex.wordpress.org/Using_Permalinks”
    its more confusing.
    Any concrete solution?

Viewing 11 replies - 1 through 11 (of 11 total)
  • esmi

    (@esmi)

    Forum Moderator

    Check that mod_rewrite is running on your server.

    Thanks esmi

    mod_rewrite is not running on apche server.

    How can I run it?

    how to resolve this?

    esmi

    (@esmi)

    Forum Moderator

    Ask your hosts to activate mod_rewrite on your remote server.

    Is the solution the same thing for a local install? Are there any tutorials for this? It seems like a relatively common problem but I’ve been pulling my hair out over this. I’ve only found a lot of vague info on editing .htaccess which I haven’t been able to accomplish. I’m running MAMP 2.0.5 on Mac OS 10.6.8. Thanks

    thanks esmi,

    I resolved the problem on localhost.

    I am using XP. I followed these steps. Hope, it may be useful for Mac OS.

    apache > Conf and find the file httpd.conf. Open that in a text editor. Use the search facility in the editor to find “rewrite”. The line you need looks like this:
    #LoadModule rewrite_module modules/mod_rewrite.so

    You need to take away the hash sign so it looks like this
    LoadModule rewrite_module modules/mod_rewrite.so

    Now just save the file.

    Thanks for the reply deep4project,
    I have found the httpd.conf file, it resides in

    Applications/MAMP/conf/apache/httpd.conf

    However, the LoadModule rewrite_module modules/mod_rewrite.so line is already uncommented, so I can’t understand why I am still getting the “You should update your .htaccess now.” error.

    Sorry ScottyChoc,

    But I don’t know more about this. its better if u start new forum post for that.

    Thanks for the reply,
    today I moved my local install to a live site to test some stuff. I was able to use pretty links with no problems and all of the links updated automatically. I guess my main concern was that I was going to have to fix every link but WordPress is so smart its not even an issue. big relief!

    So do you mean to say, once the site moved to live, permalink issue resolved ?

    I have a problem of permalink like: in local host , when i change default to other permalink structure, it give error page.

    Thanks,
    Chenna

    hi Chenna,

    check for the mod_rewrite on your apache server.

    if not follow these steps.

    apache > Conf and find the file httpd.conf. Open that in a text editor. Use the search facility in the editor to find “rewrite”. The line you need looks like this:
    #LoadModule rewrite_module modules/mod_rewrite.so

    You need to take away the hash sign so it looks like this
    LoadModule rewrite_module modules/mod_rewrite.so

    Now just save the file.

    oh.. thanks, but my manager don’t give permission to change in server side. And he wants the solution for that.. i break my head now!!! anyways thanks for the help!!!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Why I am getting error after setting permalink to Pagename?’ is closed to new replies.