Support » Plugin: Simple Download Monitor » Why I am getting a two page Process?

  • Resolved pasqualerose

    (@pasqualerose)


    Hi. Why am I getting a two page process to download? The green download button appears on the link I posted with this question. When someone clicks on the green download button they don’t download the document. Instead they go to a second page which has a link with the pdf name. In order to actually download the pdf someone has to click on that link, although there are no instructions on that page telling someone to do that.

    How do I set it up so the download happens when the green button is clicked?

    Thanks,

    Pat

    • This topic was modified 2 months, 2 weeks ago by  pasqualerose.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, what shortcode are you currently using?

    Plugin Author mra13

    (@mra13)

    Looks like you specified the URL of the attachment page in the download configuration. Thats why it is going to that attachement page.

    You need to enter the URL of the static file (direct link to the file) in the download item. So in your case, you need to enter the following URL in our plugin’s download item configuration then the plugin will be able to download that file.

    http://visualverse.thecreationspeaks.com/wp-content/uploads/2017/09/Mens-Devotional-Hikers.pdf

    Thanks. I don’t know how that happened. I thought I followed the suggested video (https://www.youtube.com/watch?v=L-mXbs7kp0s) step by step. Did I miss something in the video?

    I did go ahead and entered that URL, but it still doesn’t seem to be working correctly. Now the PDF can be viewed in the browser, but it’s not automatically downloading. What else I am doing incorrectly here?

    This is the short code I am using [sdm_download id=”10320″ fancy=”0″]

    Thanks. I appreciate the help.

    Pat

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi Pat, did you enable the following feature PHP Dispatch or Redirect in the download file you created?

    I did not. Do I need to do that in order to have it work correctly?

    Thanks.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Yes, please enable the above mentioned feature. Let me know how you go.

    Regards

    Ok. I don’t know how to do that. I’m just a guy with a blog. My tech knowledge is not that great.

    Is it hard to do? Is it something with a cpanel?

    Pat

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi Pat, please check the following documentation. Let me know if this helps you.

    Kind regards

    Plugin Author mra13

    (@mra13)

    Edit the download item in question from the admin area of this plugin then check the “PHP Dispatch” option and save it.

    That will force the file to be downloaded instead of showing up in the browser.

    Thanks! The “PHP Dispatch” option worked to stop the file from showing up in the browser.

    As far as the rest, I don’t know why I cannot get it to work correctly. It still does two pages before downloading. I deleted all the download pages and corresponding media from my WordPress and started over and still couldn’t get it. I must be missing something in the instructions or maybe there is something incompatible with my theme.

    That being said, I created a work around by copying the download link that shows up on the second page. I then pasted that link on the first page (see the link below) and rewrote the text within the link. I know it’s not the way it is supposed to work, but it works.

    http://visualverse.thecreationspeaks.com/finding-god-outside-download/

    Thanks again!

    Pat

    • This reply was modified 2 months, 2 weeks ago by  pasqualerose.
    • This reply was modified 2 months, 2 weeks ago by  pasqualerose.
    • This reply was modified 2 months, 2 weeks ago by  pasqualerose.
    • This reply was modified 2 months, 2 weeks ago by  pasqualerose.
    • This reply was modified 2 months, 2 weeks ago by  pasqualerose.
    • This reply was modified 2 months, 2 weeks ago by  pasqualerose.
    • This reply was modified 2 months, 2 weeks ago by  pasqualerose.
    Plugin Contributor mbrsolution

    (@mbrsolution)

    @pasqualerose, if you are happy with your setup that is great to know. If you don’t need any more help can you mark this support thread as resolved. However if you need more help, please let us know.

    Thank you

    It’s working, so I’m good for now. I’ll mark it resolved

    In the meantime I’ll try to walk through everything again on a test post and see if I can get it to run the right way.

    Thanks for the help!

    Pat

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.