Support » Plugin: Shareaholic | share buttons, related posts, social analytics & more » Why doesn't Recommended use my posts' "featured image"?

  • Resolved accozzaglia


    Great plug-in so far.

    Most of my posts have their own assigned “featured image”, but these aren’t being used by the Shareaholic Recommended tool. The Recommended tool is instead showing the generic Shareaholic lettermark. What few thumbnail images I am seeing are coming from incidental media embeddings within a post’s body (such as a YouTube link).

    Is there a way to direct the Shareaholic plugin to always use the “featured image” of a post?

    Example post

Viewing 11 replies - 1 through 11 (of 11 total)
  • I see from your website that you got them working, may I ask how you did it? I am having the same issue that you described. Thanks!

    What I ultimately did was to give up on Shareaholic’s “featured post” option and use the WordPress Related Posts plug-in instead:

    Shareaholic’s “featured posts” option is, frankly, not ready for prime time.

    Plugin Author Shareaholic


    @accozzaglia @scottmatkovich so sorry for this. Over the past few weeks we have been working hard on rolling a number of major improvements across the system. In the process a bug got rolled into a release of the Shareaholic image scraper a few weeks ago – specifically the part that resizes an image. We just discovered it and fixed it. Images should be showing up now. If they are not, please let us know and we can reset the image cache on our end. Again, sincere apologies and thank you so much for sticking by us! We really appreciate it!

    @accozzaglia we would love to “win” you back!!!

    Thanks! I just enabled the recommendations, though no images are showing yet.

    Plugin Author Shareaholic


    @scottmatkovich email us your website URL and we can take a look! —

    No worries, it started working – just needed a little time. Thank you for following up, I appreciate it!

    Plugin Author Shareaholic


    @scottmatkovich of course!

    I am having the same issue. I posted on facebook using shareaholic and the post went through but it’s only text. I couldn’t find how to adjust the settings to make sure it’s posting with the featured image to generate more interest…

    Thanks in advance,

    Hi Jaime,

    Open one of the posts on your site where our share buttons are present and right-click your mouse. From this menu, select the option to view the page source. Then, perform a ‘Find’ in your browser menu to locate the following text:


    If you find a matching string, visit the Facebook Debugger Tool and input the URL of the post. Look for any open graph errors and check if an image appears in the results. It should match the URL that you saw when you found og:image in your page source.

    By using this form, you are resetting Facebook’s cache of your page data and prompting them to scan the page again. If an image is present in the results (without any error notices concerning the size), reopen this post in your browser (or reload the post if you still have it open in another tab) and try sharing again. Does the image appear?

    If it does, you’ll need to prompt Facebook to scan other pages of your site to update their cached data by using the Debugger Tool. If this didn’t fix the problem when you shared with Facebook, I’ll need to take a look at the post you are testing. Thanks!

    I am having a similar issue to that described by @accozzaglia. The standard Shareaholics font, rather than featured images, are showing up in my recommendations as well.

    starling agency

    Is there a resolution for this for Shareaholics? The alternative, WordPress Related Posts, seems to be working for my blog posts, but I would prefer to use Shareaholics feature for my entire site. Thank you for any help.

    Hi mandielew,

    I ran a reprocessing of the images used in your recommendations. It looks like there were six where an image was not generated, but this has now been fixed. You should see the results on your site within an hour. Make sure you empty all caching before you check.

    Just in case you happen to run into a problem like this again, you can refresh the data we have indexed quite easily from within your plugin settings panel. This article will provide you with more information.

    If you need additional help with the plugin, please feel free to contact us directly by submitting a request through our support center so that we can speak with you one-on-one. Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Why doesn't Recommended use my posts' "featured image"?’ is closed to new replies.