• Hi, my registration form, after submit, just reload the page, doesn’t register any user, doesn’t redirect to any page, and just show itself again. Without any errors or warnings. Why?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @stratboy,

    It looks like a conflict with your theme or one of your plugins.
    Do you have any security plugins installed or caching plugin active?
    Please make sure to exclude Ultimate member pages from the cache.
    Do a quick conflict test so we can rule out any conflicts and see if it helps.
    Here is the doc on how to do a conflict test if you are not sure how to do it.

    Regards.

    Thread Starter stratboy

    (@stratboy)

    I tried, but I have to keep activated at least Polylang Pro and ACF Pro, otherwise my theme won’t work, and I guess UM should work at least with those 2 super used plugins.

    Also, I’m a developer, the theme is developed by me. And you can speak tech.

    The UM registration form won’t work both in your own default registration page, and in a specific page template, where I used

    echo do_shortcode('[ultimatemember form_id="xxxx"]')

    to recall it.

    Now, if my theme lacks something, you can tell me exactly what things should be there. What default wp theme features or code are required by your plugin?

    I use my themes since almost 20 years ago now, and 99% of plugins do not have troubles. My themes are really barebones. Also, I tried out another registration plugin (User Registration) and it works properly (tested both on its own registration page and if recalled by do_shortcode like above).

    Finally, by searching this forum, I’ve found out I’m not the only one with this exact issue.

    So, I don’t think it’s something of my code. Or, at least, nothing so evident. Please tell me the exact requirements of your plugin or, try to verify the current release.

    Thank you

    • This reply was modified 1 year, 2 months ago by stratboy.
    Thread Starter stratboy

    (@stratboy)

    Hey, I took a look to page source and I can see over 40 files (http requests) made by your plugin for loading css and js files. ???????

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Why doesn’t it register the user?’ is closed to new replies.