Support » Plugin: Membership 2 » Why does this plugin make my site so slow?

  • I’m running this site on a mom’s homeschool group site and when the plugin is disabled, the site is lightning fast, when I enable the plugin, it’s like molasses. Almost unbearable. Is there something I’m missing here.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @rudtek2,

    Apologies for the long delay here and to hear Membership 2 is not working properly on your site.

    Can you tell me if you see any errors in browser console (you can start that in Chrome by pressing Press Ctrl + Shift + J on Windows/Linux or Cmd + Opt + J on Mac) or in WordPress debug.log (you can see how to enable it here https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging)

    Have you tried disabling your other plugins and switching to default WP theme so we can see if there’s perhaps a conflict with other plugin on your site that’s causing this?

    Cheers,
    Predrag

    Predrag,
    Thanks for the reply! I’ve tried everything. I disabled all plugins except this one, and changed themes too. instant slow down for the plugin.

    these are the errors i get:
    12.4.1 12.4.1 background.js:1040:1
    “TabSources.prototype._fetchSourceMap threw an exception: [Exception… “Failed to open input source ‘moz-extension://44606d91-23ef-4398-b435-af75e4b88c02/js/content.min.js.map'” nsresult: “0x80520012 (NS_ERROR_FILE_NOT_FOUND)” location: “JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/DevToolsUtils.js :: mainThreadFetch :: line 514″ data: yes]
    Stack: mainThreadFetch@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/DevToolsUtils.js:514:5
    _fetchSourceMap@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:456:20
    fetchSourceMap@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:410:18
    _emitNewSource@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:208:7
    source@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:189:5
    createNonSourceMappedActor@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:340:12
    _addSource@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/script.js:1943:23
    onNewScript@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/script.js:1903:5
    inject@resource://gre/modules/ExtensionContent.jsm:334:16
    Line: 514, column: 0” ThreadSafeDevToolsUtils.js:80
    JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:542
    JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:542
    JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:542
    Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.[Learn More] http://www.lighthomeschool.net
    Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_toggleReaderMode” browser.xul
    Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xul
    TypeError: can’t access dead object[Learn More] main.js:7:42057
    TypeError: can’t access dead object[Learn More] main.js:7:42057
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. ExtensionCommon.jsm:306
    TypeError: can’t access dead object[Learn More] main.js:7:42057
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. ExtensionCommon.jsm:306
    TypeError: aTab is null[Learn More] SessionStore.jsm:2540:1

    in addition, this is being repeated in my error log:

    [29-Sep-2017 21:22:39 UTC] PHP Notice: Undefined variable: subscription in /home/light/public_html/wp-content/plugins/membership/app/model/class-ms-model-membership.php on line 2402

    any update here? it’s been 4 days?

    Plugin Author WPMU Dev – Paul Kevin

    (@paulkevini)

    Hey there @rudtek2,

    Hope you are well today and orry for the late response on this. Could you please replace this file in the directory /wp-content/plugins/membership/app/model/ and this file in the directory /wp-content/plugins/membership/app/rule/media/ . Please remember to unzip the files i the directory after the upload 🙂

    Warm Regards
    Paul Kevin

    Replaced both those files. No improvement on speed. Any other suggestions?

    any other ideas?

    Plugin Author WPMU Dev – Paul Kevin

    (@paulkevini)

    Hello @rudtek2,

    Hope you are well today. Apart from that one error related to Membership plugin, I cannot see any other reason for it to be slow. If you are using flywheel hosting, it has been known to be slow there. Membership does checks for url and if media protection is enabled, also media. Depending on how many members you have and the allocated memory that your hosting provided has set aside, this could also cause some issues with the checks Membership plugin does.

    Warm Regards
    Paul Kevin

    I am also having the same issue. I have installed P3 (Plugin Performance Profiler) and it literally adds 29 seconds on total load time.

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @kgabales

    Hope you’re doing well!

    Per WordPress forum regulations, please create a new thread and describe the issue you have. Please deactivate all the plugins on your site except P3 Profiler and Membership 2 and let us know how much time the Membership 2 plugin is loading at the backend.

    Kind regards,
    Nastia

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Why does this plugin make my site so slow?’ is closed to new replies.