Support » Fixing WordPress » Why does it take so long for ‘admin’ to login?

  • Resolved linuxlover992000


    I successfully finished a wordpress installation on my Linux box (accessible via home LAN, but not connected to the Internet!).

    All goes well and I even able to login as ‘admin’, but it takes a minutes or so before getting the Dashboard.

    Getting to any other page as admin is OK (Write, Manage, Options, etc.) – but getting to the Dashboard is painfully slow.

    Why? Why is this particular page slow?


    P.S. I am running MySQL 4.1.14, phpMyAdmin – on Fedora Core 4 – and WordPress 2.0.2.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Another interesting detail about my setup – perhaps it is related to the problem: Since my Linux server (used for hosting wordpress) is disconnected from the Internet, I gave an invalid email address for ‘admin’ (admin@localhost.home).

    Could that be related?

    Does WordPress attempt to contact the Internet when performing login? The login takes MINUTES…


    Yup. It does attempt to connect to the internet to load up those feeds on the main page. A bit of a pain in the butt really (search around here for some ways to disable that via plugins or core code edits).

    I tend to not use the admin link, but just jump past it with a link like: http://yourhost/blog/wp-admin/edit.php

    Chris Behm’s “Daskboard options” plugin allows you to disable feeds, amongst other things. Look here:

    Thanks for the two tips. Currently the plugin option looks very attractive.

    I downloaded the package and unzipped it into the wp-content/plugins directory. In there there are two index.php files: one for “pre wp2.0 admin” and the other is for “wp2.0 admin index”. The README for this plugin says “Rename appropriate index.php file and place in your wp-admin folder if you do not have a custom setup”.

    So I renamed wp2.0 admin index.php to index.php, copied it to the wp-admin directory and reloaded the dashboard page… only to get a blank page with nothing in it. 🙁

    Fortunately I saved the original index.php so I was able to return to install state in no time.

    Now I am wondring: does that plugin really work for WordPress 2.0.2?


    However, when I went to that link it says that it was written for WordPress version 1.5. I am using version 2.0.2.

    Do you happen to know if that matters?

    That, I don’t know. The version I use is for WP1.52 and that worked. Are you able to check your webserver logfiles to see if there were any errors that caused the blank page? If you don’t know what I’m talking about contact your host provider and ask them to supply you with logfile output for the day.

    What I did to “disable” those feeds, is simply to edit my wp-admin/index.php and took out the lines associated with those feeds.

    If I ever wanted those feeds back, I can just upgrade my WordPress to the latest and things will be back to normal.

    OMG! Yesterday night I was trying to install the ‘dashboardopts’ plugin suggested here and when it didn’t work I of course copied back the original index.php to the wp-admin directory.

    I thought that would restore things to exactly were they were before but to my great horror I now get only a blank page when I attempt to login (to my own blog).

    I tried extracting the original index.php from the latest.tar.tgz package that I used for installing wordpress – and copying it to the wp-admin directory – but that doesn’t seem to help either.

    Now what do I do?

    I can wipe out my wordpress database and re-install everything from scratch, but then I would loose everything that I have already written there.

    Is there a way to restore my wordpress to its original working state?

    BTW, it doesn’t have a “host provider”. I am running this entire thing locally, on a home LAN. So in a sense I am my own “host provider” (running Apache/httpd and MySQL on my own Linux box). I am learning as I go…


    OK – I succeeded restoring wordpress to its original mode operation. <sigh of relief>

    The problem was that when I was copying back-and-forth that wp-admin/index.php (via a Windows client), I didn’t notice that the file permissions changed from 644 to 660. That was critical. I retored that file permission back to 644 and all is as in before (slow as snail).

    Armed with this new knowledge (I bet the blank page I received originally was due to that file permissions problem) I will try again the plugin.

    Also note that the insturctions on the plugin author’s web site are much clearer than the few readme lines that come with the plugin. For your convenience:


    Bingo! I tried again the plugin originally suggested by pizdin_dim – this time paying attention to files permisssions (all need to have 644) and following the detailed instructions on – and everying now works like a charm.

    Login and dashboard access are fast just like all other pages in the blog.

    I will be marking this thread as RESOLVED.


    That plugin requires you modify a core wordpress file. The whole point of doing it as a plugin is so you don’t need to change the core files to add functions. This plugin breaks everytime you upgrade wordpress. I won’t be using it. I’ll continue to look for a plugin solution that doesn’t require modifications to the core files.

    And I found one that replaces the dashboard without modifying a core file,

    You can specify your own feeds, or leave it empty.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Why does it take so long for ‘admin’ to login?’ is closed to new replies.