Support » Plugin: YITH WooCommerce Ajax Product Filter » Why do filters do not appear in my shop page?

  • ResolvedPlugin Author YITHEMES

    (@yithemes)


    Check if you are using standard WooCommerce shop page, because the plugin, explicitly conveived as an extension for wooCommerce, works only in the specific pages created by WooCommerce plugin. So, if you have created a custom page to show your products (using shortcodes, widgets, page builder etc.), the plugin cannot work because it relies on specific parameters set by WooCommerce pages and that are not specified in custom pages.

    https://wordpress.org/plugins/yith-woocommerce-ajax-navigation/

Viewing 14 replies - 16 through 29 (of 29 total)
  • I’m having same issue with ENFOLD. It worked I think before most recent major woocommerce update. But it seems like all filter is just hidden. I’m thinking issue i’m having is same as the other memeber here with AVADA theme.. hope we’ll have solution soon. 🙂

    I’m having same issue with Bridge 9.5. Filter sidebar not showing.

    Plugin showing display none in category page after applied classes properly.

    Plugin Author YITHEMES

    (@yithemes)

    Hi,

    this problem just already fixed in the latest plugin version.
    Please, try to update your version of Ajax product filter plugin.
    Have a nice day
    YITH

    Hi,
    I still didn’t manage to get it to work. Whenever I load any filter it loads all products without filtering…
    I use the divi theme.
    Any ideas what might be causing the issue?
    How can I find out what the Product Container, etc are? As far as I know they’re all still standard.

    thanks

    • This reply was modified 3 years, 1 month ago by tabasco86.
    Plugin Author YITHEMES

    (@yithemes)

    Hi @tc33,

    please, can you send me the filtered url where I can see this display:none; inline stlye ?
    Thanks.
    Have a nice day
    YITH

    Hi,
    thanks for the quick reply.
    To see the page please enter: cormilu.com.br/luminarias/fios-de-luz/
    I added the following to hide the yith filter.
    div#yith-woo-ajax-navigation-21 {
    display: none;
    }
    When you make the filter visible and select any of the filter options (total product count per category is behind the name) after loading you’ll see that it shows all products.

    thanks a lot for your help.
    Have a great day & best regards,

    Plugin Author YITHEMES

    (@yithemes)

    Hi @tabasco86,

    I tested your website and I think you have a problem linked to theme and latest WC version.
    Please, can you read this link in our HelpCenter ?
    Let me know if this solution works for you or not.
    Have a nice day
    YITH

    tabasco86

    (@tabasco86)

    hi,

    thanks for the advice. that + deactivating my current filter plugin did the trick.
    have a great weekend!

    Plugin Author YITHEMES

    (@yithemes)

    You’re welcome.
    If you like our support and plugin, please give us a 5-star review!
    Thanks
    Have a nice day
    YITH

    virgi86

    (@virgi86)

    Hi I added it as widget but it appears on all the webpages, how can I add it on just single page?

    Plugin Author YITHEMES

    (@yithemes)

    Hi @virgi86,

    I’m sorry but I didn’t understand your problem.
    Please, can you explain me in which page you want to remove/show the filter?
    Thanks
    Have a nice day
    YITH

    Hello,

    Pls help me, I had this problem too, and I do what you link “Helpcenter: https://support.yithemes.com/hc/en-us/articles/223255767-Product-filter-does-not-show-filters-or-not-working-for-attributes-categories-tags-in-WooCommerce-2-6-x”.

    Now, the filter is appear, but not working. If I choose anything, the preloade is starting rotate but, give back the same list before I use the filter.

    You can try it:
    http://kulturbarlang.hu/termekkategoria/film/haborus/

    The frontend settings inside the plugin is looks OK:
    —————————————————–
    Product Containe = .products
    Shop Pagination Container = nav.woocommerce-pagination
    Result Count Container = .woocommerce-result-count
    Scroll top anchor = .yit-wcan-container
    —————————————–

    Please help me, what is the problem,
    Thank you.

    Plugin Author YITHEMES

    (@yithemes)

    Hi @amoditer,

    please do not repost the question again.
    I Replied about this here: Not working with woosidebars plugin

    Thanks for understanding.
    Have a nice day
    YITH

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘Why do filters do not appear in my shop page?’ is closed to new replies.