Support » Fixing WordPress » Why did my permalinks change?

  • Resolved Ron Killian

    (@ron-killian)


    Hello,

    For the longest time I’ve had my post permalinks set to custom structure, /%postname%.html It’s worked perfectly for at least a year.

    But the other day I published a new blog post (it’s been several months) and now my post url’s have /post/ in them. It use to be site.com/post-name.html now they are site.com/post/post-name And all my old posts are now formatted the same way. I can not edit the permalink in the post either, meaning I can not take out the “post”. The old post url’s still work though, I’ve tried some old ones.

    I’ve double checked my permalinks Settings-> Permalinks and it’s still what it use to be, the custom structure. I even resaved the settings several times. No change.

    I also checked my htaccess file, on the server, and nothing for it in there.

    The site is mainly a woocommerce site, I blog on the side. I do have a Woocommece SEO plugin, but that only does the product/product category links. I even tried deactivating it and stepping back a couple versions, no difference. Plus, none of my product urls have changed, it’s only the blog posts.

    I also deactivated my site wide SEO plugin and no difference.

    I am at a loss here. Besides what I’ve mentioned, what else controls permalinks?

    Only thing I can think is that a wordpress update made the change. Sure I’ve updated at least a couple times since my last blog post.

    If it was a wordpress update, why? More importantly, how can this be fixed/changed?

    Sure appreciate any thoughts on this. Thank you for you time.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator t-p

    (@t-p)

    To troubleshoot the issue, start with re-saving your permalink structure at Admin panel>>>Settings>>>Permalinks. WordPress will either create/rebuild the .htaccess file. If WordPress cannot automatically edit the .htaccess file( if it is not writable), then WordPress will provide manual instructions after saving the correct block of code so that you can manually add it to your .htaccess file. More Info: http://codex.wordpress.org/Using_Permalinks

    Thank you for your reply, but as I already said, I’ve done that.

    Moderator t-p

    (@t-p)

    If that did not help, then try:
    – Flushing any caching plugins you might be running, as well as server and/or browser caches. Not just your browser, but any op cache or content network cache as well such as Cloudflare. That will solve many weird JavaScript issues.
    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    resetting the plugins folder by FTP. Also remember to deactivate any plugins in the mu-plugins folder (if you have created such folder). The easiest way is to rename that folder to mu-plugins-old.
    – switching to the unedited default Theme (Twenty Sixteen) for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins).

    Yes I should have deactivated all plugins. Embarrassed. I did deactivate the ones I thought had any chance of causing the problem.

    Deactivated all and yes it was fixed. So I activated all and went one by one, deactivating till I found the problem.

    Come to find out it was the Intense shortcode plugin. Would have never thought that would be the problem. So odd. Now I need to figure out why.

    Thanks for the help and reminder 🙂

    Moderator t-p

    (@t-p)

    You are welcome 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Why did my permalinks change?’ is closed to new replies.