Why can't my authors (role) log in properly? (4 posts)

  1. bradleysue
    Posted 6 years ago #

    I just created two new users and assigned them both 'author' roles.
    But when I log out myself and try to log in to http://www.wilymanager.com/wp-admin using their username/password, instead of seeing the admin area, I am directed to the home page of my site. If I change their status to 'admin' then it works fine...but I'd rather not give them admin status.

    I am using the Wishlist Member (subscription management) plugin but I don't think that is relevant (I'm mentioning it just in case it is).

    Am I doing something very basic wrong?

  2. Oscar Gonzalez
    Posted 6 years ago #

    The wishlist member is relevant. Check this from their page:

    Login Redirection
    If you would like to control the first page your members see when they login, now you can. The best part is, you can have a different redirection page for each membership level. It’s perfect for adding welcome messages, updates, news and so much more.

    Look around settings for options about this and you should find a solution. To confirm that the plugin is doing this, disable it, clear your cache(s) and try again.

  3. bradleysue
    Posted 6 years ago #

    Thanks, you're right - when I deactivate the plugin it works fine.
    But unfortunately with Wishlist member I'm not able to select the admin view as a redirection (I can only choose one of the pages on my site). I will contact Wishlist member for more help.
    Thanks again,

  4. Shane G.
    Posted 6 years ago #


    Check with this article:



    Shane G.

Topic Closed

This topic has been closed to new replies.

About this Topic