Support » Plugin: Organize Series » why bother with update?

  • I do appreciate this plugin, honestly.
    But it requires a version of PHP that my host does not support.
    And WordPress recommended updating to the plugin’s current 2.5.10 version.
    Thus my series disappeared, because I don’t have PHP 5.6+.

    Just took me an hour to regress to plugin v2.5.2 for compatibility.

    Circle jerk.

    Plugin will blame WordPress; WordPress will blame plugin. Point is The User should have choices and an easy way to undue something that doesn’t even work with the user’s environment.

    TL;DR: don’t recommend “a new version” of software that doesn’t run on the server to begin with. Figure it out, devs.

Viewing 2 replies - 1 through 2 (of 2 total)
  • > TL;DR: don’t recommend “a new version” of software that doesn’t run on the server to begin with. Figure it out, devs.

    I’m sorry you had the experience you did. What’s alarming to me is that your host is saying they do not support 5.6+. This is the first time I’ve heard of a host saying something like that and in the course of my day to day work I’ve encountered a lot of them. What version of PHP IS your server running. I recommend looking here to see the the official list of PHP versions that are supported by PHP: http://php.net/supported-versions.php

    Also, name calling is really not necessary. I didn’t make this change to screw over users.

    I did what I could to make sure existing users would know about the upcoming version requirements. I put in a warning two versions before the release with the PHP version requirement via an admin notice, however, since there was no way for me to notify users of older Organize Series version, I also updated the Organize Series listing here in WordPress.org.

    Also, there is no way for a plugin or WordPress to be aware of what software a host will refuse to install. Again, if your host is telling you they won’t install PHP 5.6 or higher, then you may want to consider switching hosts because that’s highly unusual and alarming if you’re getting that advice. Pretty much every reputable host I’ve encountered provide an upgrade path to the latest version of PHP 7 (which will satisfy the requirements of Organize Series).

    I didn’t name call.

    If you’re referring to “circle jerk” I’m not calling *you* the circle jerk I’m describing the process as a circle jerk, which is not “name calling.”

    “there is no way for a plugin or WordPress to be aware of what software a host will refuse to install” – OK first I wasn’t talking about “install” I was talking about executing. The software “installed” fine, but it wouldn’t physically run (per PHP incompatibility). And yes it absolutely is possible, it’s called Version Compatibility, and it’s literally there in the sidebar of the plugin page on wordpress.org: https://imgur.com/a/gpDtx16 — “Requires” — unfortunately the user doesn’t see this data in the Dashboard Plugins page where one is recommended to, and I quote, “update now.”

    If the update won’t work, “why bother with update?”

    Thus the circle jerk.

    Point taken: I’ll no longer use WordPress backend Plugins page to update plugins prior to checking compatibility first – which defeats the whole purpose of using that backend page for the purpose of updating, and thereby creating a horrible experience for the user, which ultimately drives users away from a service (WordPress) that is unreliable and only creates version-frustration and a complete waste of everyone’s – yours, mine – time. The whole process stinks. I’ll let WordPress know this, too.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this review.