Support » Plugin: Asset CleanUp: Page Speed Booster » Why are hyperlinks in galleries being disabled?

  • Resolved Gemini23

    (@gemini23)


    All works well with speeding up the website but the plugin is disabling hyperlinks in images and galleries – which immediately work again when disabling the plugin.

    Can anyone advise what I need to do to rectify this issue?

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @gemini23 the plugin doesn’t just disable hyperlinks in images and galleries. That would not make any sense as the purpose of the plugin is to help you boost the page speed score.

    I’ve checked your website (without the plugin loaded) and it looks like you have a “defer” attribute added to the jQuery library causing an error in the browser’s console: “jQuery is not defined“. This is not a recommended practice (unless you really know what you’re doing; sometimes this option is enabled by developers) and I’ll advise you to remove the attribute for jQuery.

    Also, the hyperlinks that you have there have the “onclick” event attached to them and to make sure everything works properly, I’ll advise you to fix the JavaScript errors (e.g. “jQuery is not defined“) then check if the hyperlinks are working as they should.

    PS: I’ve loaded the website with /?wpacu_no_load query string appended to the URL and the “defer” attribute is still there for the JavaScript files. You’re either using a different optimization plugin that has this feature enabled or you have a custom code in your theme that adds the attribute.

    Hi – discussing via email – many thanks for your prompt support.

    Resolved – links not working only in ‘logged-in’ mode.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Why are hyperlinks in galleries being disabled?’ is closed to new replies.