Support » Plugin: Cache Enabler - WordPress Cache » Whole cache purged if change published post title

  • Resolved lozula

    (@lozula)


    I’ve noticed that if I change a published posts title (not the permalink), the whole cache is purged when I press “update”.

    This is despite having my cache expiry set to 0, none of the check boxes are ticked in the Cache Enabler settings, and when updating the post the cache enabler drop down is set to page specific.

    I’m running a fairly standard genesis themed site with Autoptimize.

    Is this expected behaviour? Other updates to the content of the post do not cause this to happen.

Viewing 13 replies - 1 through 13 (of 13 total)
  • lozula

    (@lozula)

    @keycdn – any thoughts on this? Is it expected behaviour?

    I’ve also noticed that updating a page also purges the entire cache. The lack of a response in this forum is a bit disturbing though.

    Plugin Author keycdn

    (@keycdn)

    I think this is related to backwards compatibility with the Gutenberg editor. Can you try to switch to the classic editor and check if you still have the same issue?

    Hi,

    Thanks for the response 🙂 I don’t use Gutenberg, just the classic editor (with the classic editor plugin). So the issue is still the same.

    Thanks

    Laurence

    Plugin Author keycdn

    (@keycdn)

    Did you set this on the post: Clear cache: Page specific

    See screenshot:
    https://prnt.sc/nlxslg

    Please send a screenshot of your Cache Enabler settings.

    Plugin Author keycdn

    (@keycdn)

    We’ve published version 1.3.4. Please check if the issue still exists.

    I have updated to the latest version of the plugin (1.3.4)

    The whole cache still clears if I change the post title on an already published post. It also purges if I update any page on the site.

    I have none of the settings enabled, you can see my config here:

    https://prnt.sc/nm2jxv

    • This reply was modified 3 months, 2 weeks ago by  lozula.
    Plugin Author keycdn

    (@keycdn)

    Are you using the Classic Editor plugin? It is required for backwards compatibility. And make sure “Clear cache” is set to “Page specific” on that post.

    https://prnt.sc/nn5nx9

    I am using the classic editor plugin yes. I did not realise there was an additional setting on a per page / post basis. Is there a way to make this a global setting? Currently every post has it set to completely clear the cache when I update a post, which seems unnecessary, and manually changing it for each post is something I will likely forget.

    I concur. I was the one who submitted the change to page specific as default in 1.3.2. I’m not sure why it was rolled back in 1.3.4 or what the rationale or use case is. I never want to clear the entire cache when updating just one post. For our blog, we update several posts per day which would cause the cache to be repeatedly cleared.

    This is the commit I made:
    https://github.com/keycdn/cache-enabler/commit/f8508ef3b1e0a2b3e39fd2d3daf32a7ff1233b50

    I am just keeping my change in my local version of the plugin.

    @bpang – really helpful, thanks. I’ve made that change to my plugin code and hopefully this will be the default going forward. It’s too easy to just forget this and inadvertently wipe the whole cache.

    lozula

    (@lozula)

    @bpang So I made that change and the post cache option now shows “page specific”, but the whole cache is still cleared when I update a post 🙁

    bpang

    (@bpang)

    @lozula It could be another plugin triggered the cache wipe, perhaps autooptimize, a theme, or a social sharing plugin? You might want to check out this thread to try and narrow it down:
    https://wordpress.org/support/topic/cache-keeps-getting-deleted/page/2/

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.