Support » Plugin: Code Snippets » Whoa! What the hell happened there?

  • Resolved Terence Milbourn

    (@pubdirltd)


    That last update blew my multisite out of the water!

    Changing it to safe in the config file.,,,

    service nginx restart … stil error 500

    I had to completely remove it from the plugins subdirectory in order to start the site again.

    service nginx restart … and it restarted without any further problem.

    Something has got by the quality assurance pixies Shea.

    Good luck in finding it.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Same here, WSOD, any idea how to downgrade to previous version?

    Edit: Found the method on this thread: https://wordpress.org/support/topic/version-2-10-1-crashes-sites-backend/

    • This reply was modified 4 years, 6 months ago by urshadow. Reason: Updated

    Open this file in notepad or whatever editor you use

    /code-snippets/php/class-code-snippets.php

    Go to line 60 and comment it out

    /*require_once $includes_path . ‘/import-export.php’;*/

    Then just re-upload that file and your site will be sorted. Same thing happened to our network dev environment this morning.

    New update broke my site, please fix it ASAP or let us know the solution.

    Warning: require_once(**************/wp-content/plugins/code-snippets/php/import-export.php): failed to open stream: No such file or directory in **************************/wp-content/plugins/code-snippets/php/class-code-snippets.php on line 60
    
    Fatal error: require_once(): Failed opening required '***********************/wp-content/plugins/code-snippets/php/import-export.php' (include_path='.:/opt/alt/php70/usr/share/pear') in ******************/wp-content/plugins/code-snippets/php/class-code-snippets.php on line 60

    We manage a lot of sites and had Code Snippets set as a Trusted Update in MainWP. It took down 8 sites today.
    Downloading the previous version from the repo and FTP’ing it into the sites had all sites back in a few minutes.
    Download v2.9.6 here:
    https://wordpress.org/plugins/code-snippets/advanced/

    @engagecommerce your solution fixed my problem but I wouldd suggest developers to fix it.

    Took my site down as well. Won’t be updating the others that use it.

    Bub

    (@jdenning47)

    KaBoom!!!!! Temporary repair. FTP old version (which I had a copy of) over the top of the new in wp-content/plugins and then wait for author to repair. If you straight up delete the broken one you will loose your snippets.

    • This reply was modified 4 years, 6 months ago by Bub.
    • This reply was modified 4 years, 6 months ago by Bub.
    Thread Starter Terence Milbourn

    (@pubdirltd)

    Thanks @engagecommerce that worked for me.

    Thread Starter Terence Milbourn

    (@pubdirltd)

    Oooops! Spoke to soon…

    With that line commented out, or as a result of another bug as-jet undescovered, if you try and export your snippets to an xml file, it immediately throws an error 500 again.

    We’re not out of the woods yet guys and gals.

    @edholtzman thanks! worked for me..
    It took my main customer down today.. thank god i didn’t updated all my sites!

    worse part is, the error is not still on Google 🙁
    Dont know how many people must be suffering..

    @pubdirltd Glad I could help

    @pubdirltd You can’t export your snippets because the import-export file is missing, thats whats causing the first original 500 error, its trying to call a file that doesn’t exist so commenting it out is a solution for that.

    You’ll have to wait for shea to release the fix or roll back to the previous version if you need to export your snippets right now

    George

    (@quantum_leap)

    Are you kidding me? That is unacceptable!

    Broke my site too, reverted back to 2.10.0

    engagecommerce, your fix worked on my site too, thank you. CodeSnippets author, please let us know in this thread what went wrong?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Whoa! What the hell happened there?’ is closed to new replies.