Support » Plugin: WooCommerce » Whitespace between product image and gallery on initial load of lightbox product

Viewing 5 replies - 1 through 5 (of 5 total)
  • This could be a theme related issue. Add the following css in to your theme or child theme custom css. (Appearance > Customize > Custom css)

    #flex-viewport{
    height:auto!important;
    }

    Cheers 🍻

    Thread Starter chewventure

    (@chewventure)

    Hey @nazreenexe – thanks for the reply!

    I just tried what you suggested but it doesn’t seem to make any difference unfortunately. I’m completely stumped :/

    Thread Starter chewventure

    (@chewventure)

    Ok, so found the issue. There seems to be some conflict between WooCommerce’s image slider and performance optimizing plugins.

    Both Jetpack’s lazy load and SG Optimizer were causing this issue to occur. I had to deactivate both before the problem resolved…

    Glad you found the culprits 😁

    Thread Starter chewventure

    (@chewventure)

    Yup 🙂

    And if anyone else is wondering, you can still allow JetPack to perform lazy loading on the rest of the site and just exclude the Products page by putting the following code in your child theme’s functions.php:

    function is_lazyload_activated() { $condition = is_product(); if ( $condition ) return false; return true; } add_filter( 'lazyload_is_enabled', 'is_lazyload_activated', 10, 3 );

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Whitespace between product image and gallery on initial load of lightbox product’ is closed to new replies.