Whitescreen of death after upgrade WPMU 2.8.5 to WordPress 3.0 (13 posts)

  1. cheezitman
    Posted 5 years ago #


    I'm trying to upgrade wordpress MU to WordPress 3. I'm following the steps here. So I:

    1. Backed Up
    2. Deleted everything EXCEPT .htaccess wp-config.php and the wp-content directory
    3. Then I copied the wordpress 3 files over with cp -rf * /path/wordpress
    4. I see this Copy wp-content/index.php and blogs.php into your existing wp-content directory, replacing the existing copies. in the instructions, but the new wordpress does not have a blogs.php file.
    5. Then I tried to access the site, and found a whitescreen of death

    What am I doing wrong. The auto-update also results in a whitescreen.

    do I need to do something with ms-blogs.php?

  2. Yeah, there is no blogs.php in 3.0. It's been replaced with /wp-includes/ms-blogs.php.

    basically, you're updating the old files with the new ones, except for wp-conntet & wp-config. php. You'll also need to add in the new default theme.

    white screens are always always php errors. Checking the error logs are the first things you do. It could be all kinds of things at this point:
    - missing files or folders
    - missing theme
    - plugins that no longer work
    - missing plugins

    If the auto-upgrade gives you a whitescreen as well, then I;d lean towards plugins causing it. Disable them before upgrade.

  3. cheezitman
    Posted 5 years ago #

    Thanks, I'll take a look at the plugins first, I thought I'd mass disabled them, but perhaps not. Do you have a good theme to suggest I switch to before upgrading?

  4. If you're using a theme that has hardcoded references to plugins, just pick one that doesn't.

  5. cheezitman
    Posted 5 years ago #

    Ok, I have WordPress upgraded now, but when I try to update the network I go through several blogs and get get:

    Warning! Problem updating . Your server may not be able to connect to sites running on it. Error message: A valid URL was not provided.

    What's going on?

  6. It means when it gets t that blog, it's getting an error of some sort. Go visit that blog.

  7. cheezitman
    Posted 5 years ago #

    It's giving me:

    Not Found

    The requested URL /nerickson was not found on this server.

    And as I've checked it's giving me that on every blog. Now when I run update network it gives me the same error, but not specific blog referenced.

    I thought it could be some problem with .htaccess just not rewriting the URLs right, but I tried a couple recommended .htaccess overrides like below:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    But so far no joy.

  8. cheezitman
    Posted 5 years ago #

    It does seem to be a problem like: this . However it's a premium site and I can't see if they solved it or not, or ask a question.

  9. It's not an .htacess issue. :) That's only used when serving up the blog in a browser, not during the upgrade process.

    You may need to disable all your plugin, *including* those in the mu-plugins folder.

    Remember, the upgrade all blogs button in the backend there just steps thru and does an db changes needed. the same hook is fired when a user visits the backend of their blog. So, if it does fail, usually it's no biggee. the blogs get upgraded anyway, since you already upgraded the code they all share.

  10. cheezitman
    Posted 5 years ago #

    But visiting any blog except the root gives me.

    The requested URL /nerickson was not found on this server.

    So I can't visit any subblog, it just fails. That's why I was suspecting a rewrite rule was wrong. Any blog in a subdirectory like http://blogs.Mysite.net/nerickson give me the above result.

    Also I'd disabled all plugins before upgrading.

  11. If they are all trying to redirect to one specific blog, it's gotta be a snippet of code somewhere.

    Could force an upgrade too, by visiting /wp-admin/upgrade.php (I think, I'm fuzzy on that location).

  12. cheezitman
    Posted 5 years ago #

    It's not a snippet of code. I was using that as an example. Any blog I visit has the same error message, backend or frontend. So that's why I can't update network, for some reason I can't bring up any blog except the root of the site.

    I'm using subdirectories like:




    And the site http://blog.something.net/ works, but the blogs of my users do not.

    That's why I suspected a rewrite rule being wrong. I appreciate the help, but I'm not making any progress it seems.the path to upgrade.php was correct btw.

  13. I meant a snippet of code elsewhere, as in a plugin.

    YES the htaccess file generates the subfolder blogs.

    Can you visit any permalinks off the main blog?

    (also possibly clearer upgrade instructions were here: http://wpmututorials.com/how-to/upgrading-from-wpmu-to-wp-3-0/ )

    As a side note, it's really hard to troubleshoot a site if we can't see the URL.

    MU htaccess file is here:

    for comparison purposes. (note the BASE line, yours is fine)

Topic Closed

This topic has been closed to new replies.

About this Topic