Support » Localhost Installs » Whitepage after changing localhost to ip in Admin

  • Resolved freekster

    (@freekster)


    Newbie here. I had built site almost ready locally and tried to test it with iPhone. I found instructions to change the localhost to my own IP in the wp admin and after that i only get white page. Neither the site or admin page loads. If i go to the IP, i get the root listing and if i click the wp-site folder/name i get white page.

    I have tried to add to wp-config.php these lines:
    define(‘WP_HOME’,’http://192.168.0.105)’;
    define(‘WP_SITEURL’,’http://192.168.0.105)’;

    No help. Then tried to change to these:
    define(‘WP_HOME’,’http://localhost:8888)’;
    define(‘WP_SITEURL’,’http://localhost:8888)’;

    No help. Then removed those and added these to the themes functions.php:
    update_option(‘WP_HOME’,’http://192.168.0.105)’;
    update_option(‘WP_SITEURL’,’http://192.168.0.105)’;

    Now i got first error! Some critical error that i didn’t write down πŸ™
    Then i changed wp-debug to TRUE and got this error:
    Parse error: syntax error, unexpected ‘;’, expecting ‘)’ in /***/wp-content/themes/astra-child/functions.php on line 27

    After i went to change that line on themes functions.php i’m back to square one: either No Network connection or white page. I cannot get any errors anymore even if everything is the same.

    Last thing i tried: I changed SITEURL and HOME in MySQL to: localhost
    I can’t find anywhere what the default valua should be so i just tried that and it does not work. Or it does something: Now i get “unable to connect” rather than whitepage.

    Is there anyway to undo that change that i did in the admin?
    No, i don’t have backup πŸ™ I was thinking that this local version is the backup for the online version and never thought i could break it locally.

    Thanks!

    • This topic was modified 5 months ago by freekster.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Howdy!

    My initial question here would be what were you using for localhost? XAMPP/MAMP/wamp?

    Thread Starter freekster

    (@freekster)

    Hi,

    I’m using MAMP on macOS.

    Thread Starter freekster

    (@freekster)

    Ok, i figured it out finally!

    After having (not so) good night sleep, i made second WP install and copied MySQL values from that to my actual site db.

    The default value is: http://localhost:8888/sitename.

    This is my first WP project and site launch is in three days. I still need to figure out how i can test with mobile as it seems that the menus might not work.

    Next headache is how to transfer the instal to server.

    Thread Starter freekster

    (@freekster)

    And i got the mobile test working. I had the url in wrong format it has to have the :8888 after the IP address.

    Good thing i got it working as the site is buggy as hell in mobile πŸ™

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Oh, that’s great you were able to get things working.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.