Support » Plugin: Classic Editor » White Text on White Background

  • Resolved migster

    (@migster)


    I have two issues with the plugin.

    The first is that, when the editor loads, it defaults to the Text editor, not Visual. This is regardless of what is set in my profile.

    Secondly, if adding text to the editor in Text mode, it is white text on a white background. By switching to Visual and then back to Text, the problem goes away and stays way.

    Neither are critical, and are quite minor annoyances in the scheme of things. I’m not even sure it’s not a WP5 issue, rather than the plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • i have the same issue , white text and there is no way to change it because there are no editing options , the top 2 rows which include editing the text disappeared, i have only the text box with white text

    Plugin Author Andrew Ozz

    (@azaozz)

    Thanks Andrew for the response. yes , same problem and i found the solution.

    After days of researching , I found that the problem is with the .htaccess file in the wp-includes folder which was causing conflicts.

    I did a backup for wp-includes/.htaccess, then i did empty the file, then reloaded the page, and the problem is solved. Everything back to normal.

    Plugin Author Andrew Ozz

    (@azaozz)

    Ah, there must have been some restrictions in there. Glad to hear it works now.

    Andrew; location of file that kills editor… wordpress/includes/js/.htaccess

    What it says is ….: AddHandler application/x-httpd-php5 .js

    Delete that file and classic editor works properly… text and visual.

    In addition the ‘block’ editor now functions as well …

    • This reply was modified 3 years, 5 months ago by diaho.
    • This reply was modified 3 years, 5 months ago by diaho.
    Thread Starter migster

    (@migster)

    The main problem does seem to be when an .htaccess rule tries to load a second php version, which does tie in with the variations on that subject which people have mentioned.

    For some reason, my .htaccess had two lines, one loading php7.2 (which is what showed in phpinfo and one which then tried to load php7.1

    Deleting the second line has solved the white on white problem, but the classic editor still loads in Text mode as default, instead of Visual mode. Switching to Visual loads TinyMCE okay, so I don’t think it’s any kind of permissions or blacklist issue.

    My profile has the option to disable Visual mode unchecked.

    (@migster)

    Try remarking the php7.2 line out of the htaccess and see what happens…. Because I completely removed the htaccess file, I indicated above, and everything came to life… I believe that somewhere in the latest update, there must be reference to this issue and leftover htaccess files like this (from previous plugin’s or editions) are no longer needed. That’s my thinking on the subject…

    I’m running into the same error. In my case, it seems to take a while for the toolbar and the text on the Visual tab to appear. It seems to be trying to load something remotely. The console in Chrome reports the following errors:

    GET https://static.zemanta.com/plugins/wordpress-wprp/loader.js net::ERR_CONNECTION_REFUSED
    10?v=2.0:6 WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Error during WebSocket handshake: Unexpected response code: 403
    v @ ?v=2.0:6
    _ @ ?v=2.0:6
    o @ ?v=2.0:6

    It eventually displays the toolbar and text, and I can continue normally. But when I save a draft with the Save Draft link, the problem recurs. I have checked everything listed, applied the SSL Insecure Content Fixer plugin to fix http/https mixed content, and upgraded to PHP 7.2. Any suggestion? Thanks.

    (@migster)

    I would suggest starting a new thread with your problem… this one is marked resolved… I posted hoping the plugin author would see what I found…

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘White Text on White Background’ is closed to new replies.