WordPress.org

Support

Support » How-To and Troubleshooting » WHITE TEXT IN VISUAL EDITOR – PLEASE HELP! (why am I screaming?)

WHITE TEXT IN VISUAL EDITOR – PLEASE HELP! (why am I screaming?)

  • Hello everyone!

    Here’s the deal. Ever since I upgraded to 2.8 editing and adding new posts has been a mess. When adding a new post or even during editing an existing post all my text in my Visual Editor appears as white and with HTML code (?!).

    I’ve deactivated all plugins, upgraded to 2.8.1, and still no change. I’ve seen other posts similar to this problem but I haven’t found the solution to my problem.

    Please help!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Check your single.php for any font colors of FFFFFF.. if you want it black it should be 000000

    check your template in appearence/editor.. on the right is your page templates.

    Thanks for the response!

    I’m not exactly sure if I’m following you though. Can you walk me through what you are talking about?

    esmi

    @esmi

    Forum Moderator

    @barngamerz: It’s an Admin issue – not a display issue on the public side of the site.

    @voneaglehausen: Have you tried:

    – disabling Google Gears if you have that running/installed.

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems.

    renaming the plugins folder via FTP

    – reading http://wordpress.org/support/topic/279132

    Thanks esmi!

    – I don’t have Google Gears running/installed

    – Currently all my plugins are deactivated

    – I’ll give switching the theme a try

    – The “renaming the plugins folder via FTP” doesn’t mention anything about this specific problem.

    – The 2.8 problems and solutions doesn’t seem to answer the question either.

    I appreciate the suggestions!

    Any other ideas?!

    esmi

    @esmi

    Forum Moderator

    The “renaming the plugins folder via FTP” doesn’t mention anything about this specific problem

    No it won’t. The link is there to tell you how to do it. Occasionally even an “inactive” plugin can cause problems. Renaming the plugins folder via FTP is the simplest way to ensure that this isn’t happening in your case. It’s either that or editing your database.

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    @voneaglehausen is the visual editor loading (if it is you’ll see the buttons)? If it’s not, did you try all steps in http://wordpress.org/support/topic/279132 as suggested by esmi? Usually one of these fixes it:
    * try clearing the cache and/or another browser,
    * go to “site url/wp-includes/js/tinymce/wp-tinymce.php?c=1” in Firefox, you should see a large Javascript file. If not, download the install package, extract it and then replace all files in the “/wp-includes/js/tinymce/” directory with FTP,
    * add define('CONCATENATE_SCRIPTS', false); in wp-config.php (near the top on a new line).

    Wow, thanks a lot azaozz! I’ll try those suggestions.

    I had the same problem. Using another browser worked, so I figured it was due to a corrupt cache file.

    CLEAR THE BROWSER CACHE TO GET RID OF THE PROBLEM 🙂

    Thanks for the hints

    None of these solutions worked for me.

    I had this problem and just fixed it. Go into the w-admin folder. Then go to the file wp-admin.css open it a text editor. Locate the line .js.theEditor (it’s easiest if you use find and type it in). By default for some reason this is set to white. Change it to black and then re-upload it.
    Hope that helps.

    Thanks A LOT Azaozz for your tips !

    I’ve checked my /wp-includes/js/tinymce/wp-tinymce.php?c= as you said. 404 error page. So I’ve checked all my /wp-includes/js/ directory… a lot of files and directories was missing !!!

    As you suggested I downloaded a new WordPress file and uploaded all the /wp-includes/js/ content. My post editor works now !!!

    Thank you a lot.
    ++

    Sangy

    missk, your solution worked for me!!! Thank you!

    The concatenate thing worked 😉 thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WHITE TEXT IN VISUAL EDITOR – PLEASE HELP! (why am I screaming?)’ is closed to new replies.