Support » Plugin: Minify HTML » White Space Character Before HTML Tags Are Suppressed by Error

  • Resolved WebHostingHero

    (@stephane74)


    Since one of the recent updates, the plugin suppresses white spaces before each html tag.

    For instance:

    <p>hello <strong>world</strong></p>

    Displays as:

    helloworld

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter WebHostingHero

    (@stephane74)

    I should add that only the first space character before each tag is suppressed. If there are two spaces before an HTML tag, only will remain. Here’s another example:

    <p>hello <strong>world</strong></p>

    Will display this in the source code of the published post (1 space char suppressed):

    <p>hello <strong>world</strong></p>

    And this will be displayed by the browser:

    hello world

    Sorry for my english btw.

    Plugin Author Tim Eckel

    (@teckel)

    The only change in functionality would be if you turned on the new “Support multi-byte UTF-8 encoding” option (defaults to off). If that is turned off, it should have the same functionality as previous versions. If you turned that new option on, it sounds like you should turn it off.

    Without seeing your site, it’s impossible to diagnose. Let me know what your Minify HTML settings are and make sure the “Support multi-byte UTF-8 encoding” option is turned off. If you still have an issue, it would be best if you should provide a link to your site.

    Tim

    Plugin Author Tim Eckel

    (@teckel)

    I can confirm that this can be caused by the new “Support multi-byte UTF-8 encoding” option being activated. Set this option to “No” if you experience this (which is the default and suggested setting).

    Tim

    Thread Starter WebHostingHero

    (@stephane74)

    Hi Tim,

    Indeed, disabling “Support multi-byte UTF-8 encoding” solved the issue.

    Thank you!

    Stephane
    WebHostingHero.com

    Hi Tim,

    I’m experiencing the same issue. We definitely don’t have the new option turned on, but it looks like the if statement that checks the option is causing the feature to default to “on” if don’t specifically update the options on each site you use the plugin on (in my case, that’s 300+).

    I’d like to propose a fix that would solve this. Happy to submit a pull request if you’ve got the code in git. Otherwise, here’s the corrected if statement for line 47:

    if ( $minify_html_utf8 == 'yes' && mb_detect_encoding($buffer, 'UTF-8', true) )

    • This reply was modified 4 years, 10 months ago by Maura Teal. Reason: fix code tags
    Plugin Author Tim Eckel

    (@teckel)

    You’re right, will update to v1.98 in an hour or so. Thanks for the heads up!

    Tim

    Plugin Author Tim Eckel

    (@teckel)

    v1.98 is now available fixing this, thanks again!

    Tim

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘White Space Character Before HTML Tags Are Suppressed by Error’ is closed to new replies.