Support » Plugin: Smart Slider 3 » White space below menu

  • Resolved Edwin

    (@mmhgloba)


    Hello, there is a white space between Smart Slider 3 and the header secondary menu (on all devices). I have tried all the options listed here but none of them work. Additionally, I have contacted the theme developer and they sent me some code which partially solved the problem (the white space used to be much larger).

    This is the current code I am using:

    .home #content-sidebar,.home #content #post-2 {
    padding-top: 0 !important;
    }

    #main {
    margin-top: -20px;
    }

    Any feedback you can provide will be much appreciated. The Smart Slider needs to be against the menu with no white space on all devices.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 16 through 28 (of 28 total)
  • Plugin Support Laszlo

    (@laszloszalvak)

    Hi @mmhgloba

    As for the CSS:
    The other two CSS on the other two container elements are still necessary for reducing that space. So all the CSS you need is:

    div#main #content-sidebar{
      padding-top: 0;
    }
    div#main header.entry-header{
      margin-bottom:0px;
    }
    div#main #content > article{
      padding-top: 0;
    }

    Sorry in my previous reply with the margin/padding parts I meant that, the CSS that targeted the “article” element, has a margin and padding property as well that is not necessary in your posts.

    As for the Anchor:
    Currently there is no ID on your <h1> element under the slider.
    Just for an example:
    if you would add a HTML ID – https://www.w3schools.com/tags/att_global_id.asp – on your text: “Buddhist Gods, Buddhist Deities, Dharmapala” with the <h1> tag. Then you could simply write that ID of that element with an # before it, into the Link field of the Button layer: https://smartslider.helpscoutdocs.com/article/1834-button-layer#link

    Thread Starter Edwin

    (@mmhgloba)

    Hi Laszlo,

    Thanks for your insights. That page seems to be working fine now.

    I have a small issue with my other website iglobal.net I have made some changes to the wording in the home page Header but the changes will not transfer to the live home page. The changes are saved, and I can view them in the wordpress customizer.

    I deleted the heading words and reinserted them hoping it would clear it up, but now the header is just blank. This is very frustrating. Why is it doing this?

    Thank you,
    Edwin

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @mmhgloba

    I checked the “iglobal.net” domain and the slider in the header section ( title: Economic Citizenship, Global Access & Security ) appears fine for me currently.

    But what I noticed is that your page is cached by a caching plugin: LiteSpeed Cache
    and currently display the results according to the state that was generated on 2020-08-01 20:08:47.

    So simply clearing the cache of LiteSpeed Cache will most likely fix the problem!

    Thread Starter Edwin

    (@mmhgloba)

    Ok, thanks for pointing that out. I just installed that plugin at the behest of the domain host. I will look out for that issue in the future.

    Thread Starter Edwin

    (@mmhgloba)

    Something else I have been meaning to ask you is about my heading getting hyphenated by browsers, especially chrome. I have also noticed this issue with post titles. For example if you go to my website home page iglobal.net on your mobile phone using the chrome browser you will see that they have hyphenated the word Eco-nomic and it looks terrible. The Mozilla browser does not do this, they just drop the word down to the next line. How do I resolve this? In posts I insert the <nobr> tag into the html. But I do not know how to do it in smart slider. I tried it in smart slider but it is not working. Thanks for your insights about this.

    Plugin Support Gabor

    (@nextendweb_gabor)

    Hi @mmhgloba!

    We check it out, but couldn’t see the problem in our Chrome browsers, but what we saw was, that your theme has this code:
    https://iglobal.net/wp-content/themes/adventurous-pro/style.css

    #content article {
    	word-wrap: break-word;
    	-webkit-hyphens: auto;
    	-moz-hyphens: auto;
    	hyphens: auto;
    }

    which could create hyphens and break words. I suggest trying out this code:

    body #content article {
    	word-wrap: normal;
    	-webkit-hyphens: none;
    	-moz-hyphens: none;
    	hyphens: none;
    }

    to overwrite your theme’s. If you don’t have a good place to put css codes, you could use a plugin like this one:
    https://wordpress.org/plugins/simple-css/
    which will create an option for you in the WP left admin menu’s Appearance -> Simple CSS.

    If you would still see the same problem after this, please tell me what is the operation system (and its version number) of your phone and also tell me the version number of your Chrome!

    Thread Starter Edwin

    (@mmhgloba)

    Thanks for your insights, so far so good. If I could ask one more question….is it possible to use some of the excess space on the left and right side of the screen for the header? It seems stuck in the middle 1/3 of the screen. I am trying to create more space but no luck. Is it possible to widen the header space?

    Plugin Support Gabor

    (@nextendweb_gabor)

    Some setting seems to be giving a maximum width to your content, like as you see here:

    on the content layer you can set a maximum width, even device specifically. You should check this value first, to make sure it isn’t too narrow.

    Then on the Size tab:
    https://smartslider.helpscoutdocs.com/article/1774-slider-settings-size
    the “Limit slide width” setting could also limit down the maximum width of your contents.

    If these won’t help, please send me an export of your slider through this form:
    https://smartslider3.com/contact-us/support/?topic=Editing&platform=WordPress&version=Free&website=website-yes&send-screenshot=sreenshot-no&slider-export=slider-yes
    and we will check out its settings!

    Thread Starter Edwin

    (@mmhgloba)

    Hello, thanks for your input on the above. There is an additional issue. Regarding the button, I have the font set to “300 – Light” however, in practice when looking at the home page slider in laptop and then on mobile…there is a big difference. In mobile it seems to display as “Light” font but on lap top it is heavier font weight. Can you assist? Thank you. Website url is iglobal.net

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @mmhgloba

    The Average font family you’re using doesn’t seem to support the 300 weight, or any other weight other than the normal (400):
    https://fonts.google.com/specimen/Average#standard-styles
    Probably that causes the rendering issue with the browsers.

    If you want to have a 300 font weight, you should rather use a font family which actually supports it.

    Thread Starter Edwin

    (@mmhgloba)

    Hello, thanks for the clarification. I ran into another issue, perhaps it is related to the new updates.

    In my post located here: https://goldenbuddha.net/leshan-giant-buddha-statue/

    I installed the smart slider short code because I wanted the large image to enhance the post. However, it only appears large in desktop browsers. In mobile and tablet it is just a slim line at the top of the post. I tried to enlarge the image by increasing the depth in mobile, but for some reason this is no longer working.

    I have done it before with smart slider images in other posts. For example: https://goldenbuddha.net/buddhist-gods-guide-buddhist-pantheon/

    Why isn’t it working with this post?

    Plugin Support Gabor

    (@nextendweb_gabor)

    Hi @mmhgloba!

    On the Size tab of your slider’s settings:
    https://smartslider.helpscoutdocs.com/article/1774-slider-settings-size
    you should use the Minimum height option:
    https://smartslider.helpscoutdocs.com/article/1774-slider-settings-size#layout

    On your working example you might used the padding on the content layer:
    https://smartslider.helpscoutdocs.com/article/1810-content-layer
    to create some space which is always kept, but the Minimum height option should do the same for you.

    Thread Starter Edwin

    (@mmhgloba)

    Thank you, I set the min height and that fixed it.

Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘White space below menu’ is closed to new replies.