WordPress.org

Support

Support » How-To and Troubleshooting » White space below header and above first entry on home page

White space below header and above first entry on home page

  • I was able to find how to change the name of each page to white text, but I want to get rid of the text completely on all the pages which are static pages as it still pushes the beginning entries on any page down and viewers are forced to scroll down to see them.

Viewing 8 replies - 1 through 8 (of 8 total)
  • link maybe?

    😉

    I believe the space is there because I did not get rid of the text. I only concealed it by making it white, but could not find where I could tell the program to remove it totally.

    Moderator Michael

    @alchymyth

    Forum Moderator

    to allow a purposeful reply, please post more detailed information such as a link to your site, the name of your theme, your edits to turn the page title white, ….

    might be a css issue in which case you better ask at a css forum http://csscreator.com/forum

    I’m sorry I left out the link. I thought I put it in the original post, but obviously not. I’m using theme 2011. The web address is http://www.napagop.org. Thank you for the link to the csscreator forum. I will go there and have a look to see if there is an answer there. But if you have any insight into this problem, please feel free to let me know how I can correct it.

    Moderator Michael

    @alchymyth

    Forum Moderator

    have you searched the forum for ‘removing/hiding the page title in Twenty Eleven’ ?

    there are a lot of solved topics around that question, and other questions regarding that theme.

    start by creating a child theme of Twenty Eleven for the customisations; http://codex.wordpress.org/Child_Themes

    or use a custom css plugin.

    a posibly css quickfix:

    .page .entry-title { display: none; }

    You could hide that text in two different ways.

    1) I see it is wrapped as an h1 with class entry-title, so by doing this on style.css you would hide it:

    .entry-title {display: none;}

    2) BUT, you would also be hiding all of the blog posts’ titles. So if your aim is to hide it only from THAT page, you could replace the following line from your loop:
    <?php the_title('<h1>', '</h1>'); ?> or <h1><?php the_title(); ?></h1>

    with

    <?php
    if ( !(is_home()) ) {
        <h1><?php the_title(); ?></h1>
    }
    ?>

    Good luck!

    Moderator Michael

    @alchymyth

    Forum Moderator

    BUT, you would also be hiding all of the blog posts’ titles

    therefore the suggested addition of .page in my code which is the body_class output for static pages.
    a front page would have the css class .home

    and, yes, editing the title code in content-page.php with or without a conditional statement is also an option – for a static front page this would be is_front_page().

    Thank you both for your reponses. I finally had a chance to try your suggestions. I ended up pasting .entry-title {display: none;} in the stylesheet (style.css) and it worked.

    I do need to create my Child Themes. I started to do it some time ago, but never got it completed.

    Again, thank you for your help.

    Glenn Ellen

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘White space below header and above first entry on home page’ is closed to new replies.