Support » Themes and Templates » [Resolved] White space after posts

[Resolved] White space after posts

  • Hi all.

    I am having a bit of trouble with some white space after my posts. This is only on the single post pages but I just can’t work out why!

    If anyone has a chance to look I would appreciate any ideas you may have. The site is at http://www.stjb.org.uk and it is only when I view single posts – so any of the links on the right hand side should show you the problem.

    Thanks if anyone does!

    Also – I am still having issues to double displaying of single posts if I give the post more than one category! Any suggestions…

    PS Sorry if this isn’t enough information or comes across as lazy – as always – I am happy for you just to point me in the right direction… I have searched the forums for similar things but none of the answers given so far help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    It looks the same to me on the main page and the single post pages. Could you post a screenshot of what you’re talking about, or maybe just be more specific about your setup or what exactly you are seeing?

    Thanks for taking a look Otto.

    I have posted 2 screenshots – sorry about the quality – only have access to Paint at the moment! The first is of the front page as I see it (in Firefox on a PC but the same in IE 6 & 7 on the same PC). The second is of a single post. The red box doesn’t appear – but the white space within that box is what I don’t want!

    I am using WordPress 2. The pages validate to xhtml 1 transitional. I’ve tried disabling plugins (that always seems to be the first suggestion people make!) And I have had a look at the code for my single post. I can’t see anything that would cause this but I will probably have missed something.

    Right – I will try to include my single post code but usually the coding goes wrong for me!:

    <?php get_header(); ?>
    <div class="container" id="content_banner">
    <img class="left"
    alt="Banner" />
    <div id="content_body">
    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>
    <div class="post" id="post-<?php the_ID(); ?>">
    <h4><a href="<?php the_permalink() ?>" rel="bookmark"
    title="Permanent Link to <?php the_title(); ?>">
    <?php the_title(); ?></a></h4>
    <?php the_content('Read the rest of this entry &raquo;'); ?>
    <p class="small">Posted on: <?php the_time('j F Y') ?>
    Category: <?php the_category(', ') ?> |
    <?php edit_post_link(); ?>
    <?php endwhile; ?>
    <?php else : ?>
    <?php endif; ?>
    <?php get_footer(); ?>

    I can’t find anything in my css that would cause it either.

    Is that enough info now? I hope so. Sorry if it doesn’t post correctly…


    And yeah – I know I should probably have something in the ‘else’ section but I don’t! I did have the ‘sorry, no posts match your criteria’ thing but that didn’t make any difference!

    Sorry Otto – it was within the CSS that I found the trouble.

    Thanks again for taking a look.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] White space after posts’ is closed to new replies.