WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] White Screen without www, unable to log in

[Resolved] White Screen without www, unable to log in

  • Hey everyone,

    Moved a website from rackspace to a mediatemple grid service box and am having multiple problems.

    If I don’t type in www before the website it only loads a blank white page. Typing in http://www.website.com brings it up. However, when I click on a link it says the requested URL was not found on this server.

    I’m also unable to log in. No error, it just goes to a blank white page.

    What is odd was that the website was working on the website.com.sxxxxx.gridserver.com. It all broke when we pointed the domain to the new server.

Viewing 14 replies - 1 through 14 (of 14 total)
  • WPChina

    @wordpresschina

    This may be a number of reasons. I think I would first do this:

    1) Go into wp-content/cache and delete all cache files if I am using a caching plugin

    2) Your DNS may not be updated yet fully. Ping both http://www.domain.com and domain.com and see if it really does point to the new server.

    3) Temporarily remove your htaccess file and see if it loads now. If it does, run Permalinks again and a new htaccess file should be generated

    Thanks for the quick response.

    1) No cache folder in wp-content.

    2) Pinged both and they both go to the same new server ip address.

    3) Removed htaccess and exhibited no change.

    WPChina

    @wordpresschina

    4) Try a different browser and check if it comes up

    5) mediatemple has good WordPress support, so tell them of the issue and they may have a solution. It might be something on their end.

    4) Good idea. No luck 🙁

    5) I have always been impressed with their support. They spent a good ten minutes with me if not more but they couldn’t fix it either.

    WPChina

    @wordpresschina

    I have had this problem in the past a few times when moving, but the solution always seems to be different. I would usually think it was a DNS issue on the server, but the caching sometimes also is an issue.

    Go into the databasse via phpmyadmin and check the wp_options to just verify the site has the www attached — I know this is probably repetitive but it doesn’t help trying.

    also try going to http://www.domain.com/wp-login.php for backend?

    I don’t mind trying things twice.

    in the siturl field the full url is listed http://www.domain.com

    When I go to wp-login I get the form, but then when I press enter the screen goes white and the url doesn’t change at the top.

    WPChina

    @wordpresschina

    so if you go to domain.com/login.php you can login fine, but if you go to the www. it does show you the login page but it doesn’t allow you to login and instead goes to white page?

    Good clarification.

    I can go to either (with or without www) and I get to the login page just fine.

    Both versions (again with and without www) lead me to a white page after clicking on log in.

    WPChina

    @wordpresschina

    ok, maybe this is a php memory issue? Did your host check that? WP_MEMORY_LIMIT can be added to the wp-config.php and you should google that to find out the parameters. But WP_MEMORY_LIMIT I think is best not used and instead maybe try to do it directly on the host’s server/VPS….

    WPChina

    @wordpresschina

    Grr, no luck there.

    I turned on error reporting. Noticed it in there. And I got this error: Warning: Cannot modify header information – headers already sent by (output started at /nfs/c03/h06/mnt/167997/domains/mywebsite.com/html/wp-includes/functions.php:2628) in /nfs/c03/h06/mnt/167997/domains/mywebsite.com/html/wp-includes/pluggable.php on line 881

    This error happened with and without the plugins folder. I tried it once the same and once with plugins folder renamed to pluginsold–which with my understanding disables the plugins.

    WPChina

    @wordpresschina

    WPChina

    @wordpresschina

    Also, weirdly sometimes time solves these probelms on transfers. I have no idea why but sometimes 1 day seems to kill the gremlins in the server. But that is the witchcraft method of WordPress troubleshooting…

    what resolved the issues was actually re-writing the .htaccess file, forcing everything to www.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] White Screen without www, unable to log in’ is closed to new replies.
Skip to toolbar