Support » Plugin: Vimeotheque - Vimeo video importer WordPress plugin » white screen when I want to add a new video – vimeotheque pro

  • Resolved marinebayle

    (@marinebayle)


    Hello,

    For the past couple of days, I haven’t been able to add any new video with my plug in : Vimeotheque Pro.
    When I click on “Add new” it’s just a white screen, anything appears.

    What’s the problem ? Is it the new version ? How can I fix this ? I really need to upload a new video today and I can’t find any solution…
    Thanks a lot,

    • This topic was modified 11 months, 2 weeks ago by marinebayle.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Constantin Boiangiu

    (@constantinboiangiu)

    Hi,

    Can you take a look at your server error log and send the error you find in it? At this moment, yours is the first report of such issue.

    Until we figure this out you can use the manual bulk importer and import a single video.

    Thread Starter marinebayle

    (@marinebayle)

    Hi,

    Where can I find this info ? I’m working online and nothing appears when I click on “Add new”. The webpage just goes white. When I inspect the page it says :

    Failed to load resource: the server responded with a status of 404 ()
    But it seems to speak about that page : https://www.webinr.fr/wp-content/themes/Divi/includes/builder/scripts/failure_notice.js.map

    I don’t really understand the link between the plug in and divi. It’s not a Divi page, it’s when I’m on my dashboard, I click on “Videos” (the category on the left, related to the plug in directly) -> “Add New” then the white screen.

    Let me know if I’m clear enough !
    Thanks

    Plugin Author CodeFlavors

    (@codeflavors)

    Hi,

    The server error log should be accessible from your hosting panel (ie. cPanel or Plesk ). Your hosting provider should be able to help you with this.

    Vimeotheque and Divi don’t have any issues, we tested the two and everything works.

    Can you please tell me, do you also use Vimeotheque PRO or only the free version?

    Hello, I am having this problem as well. I opened a ticket with Siteground. I’m not seeing any specific errors. I’m using Elementor. I really need to get this working again! I am using the free version, it’s all I need and we are a non-profit.

    Thank you

    Here is my system info from the plugin:

    ### WordPress info ###

    WP URL: https://lavenderstreak.com
    Site address: https://lavenderstreak.com
    Vimeotheque version: 2.0.9
    WordPress version: 5.6
    WordPress memory limit: 40M
    WordPress debug mode: No
    Language: en_US
    WordPress multisite: No

    ### Server information ###

    Server: Apache
    PHP version: 7.3.26
    PHP post max size: 256M
    PHP time limit: 300
    PHP max input vars: 3000
    PHP default timezone: UTC
    PHP cURL: Yes
    cURL version: 7.66.0, OpenSSL/1.1.1g-fips

    ### Active theme information ###

    Active theme: Astra Child
    Theme version: 1.0.0
    Child theme: Yes

    ### Plugin settings ###

    Public (public): Yes
    Archives (archives): No
    Post slug (post_slug): vimeo-video
    Taxonomy slug (taxonomy_slug): vimeo-videos
    Tag slug (tag_slug): vimeo-tag
    Import tags (import_tags): Yes
    Max tags (max_tags): 3
    Import title (import_title): Yes
    Import description (import_description): content
    Import date (import_date): No
    Featured image (featured_image): No
    Import status (import_status): publish
    Vimeo api keys (vimeo_api_keys): Yes

    ### Embed settings ###

    Title (title): 1
    Byline (byline): 0
    Portrait (portrait): 0
    Loop (loop): 0
    Autoplay (autoplay): 0
    Color (color): #
    Dnt (dnt): 0
    Aspect ratio (aspect_ratio): 4×3
    Width (width): 640
    Video position (video_position): below-content
    Video align (video_align): align-left
    Volume (volume): 25
    Playlist loop (playlist_loop): 0
    Aspect override (aspect_override): Yes

    ### Add-ons ###

    Vimeotheque Debug: Active (version 1.0)

    Plugin Author CodeFlavors

    (@codeflavors)

    Hi,

    We recently discovered a bug that was the cause of this issue but only under certain conditions. We released version 2.0.10 to solve this, please update and let me know if everything works as expected.

    What was actually going on?

    The bug was caused only under some conditions. We found that when WooCommerce was active and the Classic editor plugin wasn’t active or installed, when loading the “Add new” screen in Vimeotheque you would end up with a blank page. The screen wasn’t a white screen of death, there were no PHP errors, the page was blank because it was hidden from CSS.

    This was caused by block scripts registered for the block editor which is loaded by Vimeotheque so that it can use React to display the video import app. The issue was solved by unregistering all blocks since they weren’t needed anyway (the block editor isn’t used into the Add new page of Vimeotheque).

    • This reply was modified 9 months, 1 week ago by CodeFlavors. Reason: typos
    • This reply was modified 9 months, 1 week ago by CodeFlavors. Reason: typos

    Thank you, this works now. Woo Hoo!

    Just to let you know, though, that I DO have classic editor installed and activated (it has been for a long time, not even sure if I need it anymore, but I did a few months ago).

    Thank you again, I’m glad that it works, it’s a wonderful plugin.

    Plugin Author CodeFlavors

    (@codeflavors)

    @lavenderstreak Thank you for your confirmation, I’m happy to hear you like the plugin, it means a lot to us.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘white screen when I want to add a new video – vimeotheque pro’ is closed to new replies.