WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] White screen – themes directory is empty or doesn't exist.

[Resolved] White screen – themes directory is empty or doesn't exist.

  • I get the following error message on my site

    “The themes directory is either empty or doesn’t exist. Please check your installation:

    I have a feeling it has something to do with my index.php file.

    http://rmi.co/thermiteam

    I can still access the Admin dashboard.

Viewing 15 replies - 1 through 15 (of 16 total)
  • problem solved.

    I’d renamed index.php, then changed the name back again. This had somehow knocked the theme off, and no themes were active.

    Reactivating the theme seems to have fixed things.

    Tried this and the issue remains.

    So, what did you do? (in a little more detail please)

    Recently, I have installed a plugin which is called meta tag manager and now i see a white page and this message on the dashboard “ERROR: The themes directory is either empty or doesn’t exist. Please check your installation” Any help?

    Can you still access the admin section of your site?

    If so, go to Editor/Themes, and make sure your theme is active.

    Also try deactivating the plugin to see if the problem persists.

    yes I access the dashboard. When I go to appearance> theme it tells that “you have one theme installed right now” but when I go to appearance>editor it tells ” this theme does not exists”. All my plugins are deactivated automatically and even they are removed totally.

    having same problem, no plugins, and it’s not the theme itself as I installed it on other blogs just fine. Any answers on this yet?

    The theme itself is activated and shows on the site fine, however I get the error referenced above, and no theme is showing under ‘current theme’. As well, going to editor says no theme was found.

    esmi

    @esmi

    Forum Moderator

    Please post your own topic.

    With all due respect Esmi, I have the exact same problem and this thread was unsolved, and recent. Why create more threads for the same exact thing?

    esmi

    @esmi

    Forum Moderator

    Are you using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster? No? Then post a new topic. It also makes life a lot easier for the forum’s volunteers (the ones who actually help you).

    Wow, wake up on the wrong side of the bed? Good lord. Nvm, I’m sure I can figure it out on my own rather then deal with your attitude. SMH

    Note that several people on here posted the same issue and were not given an attitude… instead people tried to help them.

    Any forum I’ve ever been on for support appreciates when the same exact issue is posted in one thread, so as to not clog up the forums. Pardon me for trying to be respectful.

    esmi

    @esmi

    Forum Moderator

    wake up on the wrong side of the bed?

    Hardly. It’s almost midnight where I am & I’ve already dealt with 60+ support topics on here without any problems.

    Any forum I’ve ever been on for support appreciates when the same exact issue is posted in one thread

    But that is not how these forums work. You were asked politely at first. You refused.

    I did not refuse, I politely asked you why… you didn’t have to respond with an attitude. A brief but polite response as to why it is best to post another thread would have been perfectly fine, and well received. Sorry, I don’t respond well to attitudes or snarkiness.

    @nfgoddess:

    1> Use your FTP client to verify that your index.php file hasn’t been renamed,
    2> Use your FTP client to check that your theme files are named correctly,
    3> Use your FTP client to upload a clean copy of the default WordPress 2011 or 2012 theme, then try to activate it through the Admin dashboard. If this works, download and install a new, clean version of your chosen theme, again, through the Admin dashboard so WP writes to your DB.
    4> Try and bear in mind that the moderators here are volunteers, and any suggestions are made either to help you, or other users who are searching for help on the same problem, or both. I don’t think there was anything rude in esmi’s request – each WP user has their own unique setup, if you start your own thread and are specific enough in the detail you give, you are more likely to get a response that will be tailored to your own situation.

    Thank you fishgun, I appreciate your response, and will try those things. I volunteer in forums too, and I respect others who do. I did feel an attitude in Esmi’s postings, perhaps I was wrong, as I dont know Esmi and could have misinterpreted… but thats how I felt. Regardless, I thank you for your help.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] White screen – themes directory is empty or doesn't exist.’ is closed to new replies.