WordPress.org

Forums

WP Super Cache
White Screen - Site not loading when enabled (3 posts)

  1. mypersonalaccent
    Member
    Posted 1 year ago #

    Whenever I activate this plugin my dashboard and site will not load. It just comes up in a blank white screen. I tried disabling all plugins, uninstalling, and then reinstalling and it still does the same thing.

    Any ideas?

    http://wordpress.org/plugins/wp-super-cache/

  2. Faison
    Member
    Posted 1 year ago #

    Hi Mypersonalaccent,

    I think you and I are experiencing the same issue. If you set WP_DEBUG to true, do you get an error.

    This is the error I get:
    PHP Fatal error: Internal Zend error - Missing class information for in /var/www/vhosts/[site name]/wp-content/plugins/wp-super-cache/wp-cache-base.php on line 5

    I don't know the solution, so if the developers could hop in, that'd be great!

    Thanks,
    Faison

  3. mypersonalaccent
    Member
    Posted 1 year ago #

    Interesting. That appears to be this line:

    if (!class_exists('CacheMeta')) {
    	class CacheMeta {  // this line
    		var $dynamic = false;
    		var $headers = array();
    		var $uri = '';
    		var $post = 0;
    	}
    }

    I've run it through a code checker and nothing comes up. I'm not sure how to check for that class or implement it otherwise.

    If I am correct it is saying, if CacheMeta does not exist, then run those parameters for CacheMeta.

    Amber

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic