Support » Fixing WordPress » White Screen of Doom!

  • When I try to upgrade to 2.3 from 2.2.3 I get a blank screen and the rest of my blog blows up with it. Is anyone else having this problem? How do I fix it?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Dion Hulse


    Lead Developer

    A White screen most likely means a PHP Error has occured and your webserver is set to NOT show them.

    Do you have some Error logs you can look at?

    Also, Remove any plugins that you can from your wp-content/plugins/ directory incase one of those is causing it.

    I tink UTW *might* cause such a issue on upgrading

    I never used UTW.

    Upgraded from 2.3 RC1 to 2.3 final, and now I have no Joy. (White screen of death) admin is the same way. I cant even get the logon screen. (Yes I disabled all plugins, and deleted all relevant files as instructed in the upgrade guide)

    My error log shows this message:

    PHP Fatal error: Call to undefined function: stripos() in /var/www/vhosts/ on line 37

    Any help would be greatly appreciated. πŸ˜€


    A couple things I’ve done in the past to fix the white screen of doom:

    – name the theme folder I’m using “default”
    – Re-upload all files (usually this does the trick)
    – Check the files in your ftp client, if they have ? in the file type section, refresh the ftp

    Hope that helps

    I upgraded to 2.3 and when I tried to change the theme I got the following error:

    Fatal error: Cannot redeclare visteredlittle_setup() (previously declared in /home/iyf500/public_html/wp-content/themes/vistered-little/functions.php:12) in /home/iyf500/public_html/wp-content/themes/vistered-little/functions.php on line 10

    I wish I was receiving an error message. That way I would know where to look. I changed my theme directory name to ‘default’, however it didn’t cause any change. White screen on IE7 IE6 FF and Safari.

    In researching this problem, I read somewhere that php will output a white screen whenever there is a missing ‘}’ in the code, or some other syntax error not closing the php code properly. Unfortunately I also read that the only remedy is to go through all the lines of code until you can find the offending snippet.

    I really hope someone out there has done this already and can post (hint hint) their solution. πŸ˜€


    I reuploaded the files in the root folder (all the ones that started with the ‘WP-‘ and my website came back!! yay!

    Hope this helps you.


    Ok, not sure if this belongs here, but when I reactivated my plugins. the following plugin caused my website to go white again. WP-DBManager Once I removed it, everything went back to normal. I mention this just in case you have that installed.


    I reuploaded all of the proper files and I could see my site again but I couldn’t access the admin area. I tried reinstalling again and then I could access the admin area for all of five minutes until I tried to update my site then I got the same error message.

    I don’t have that plugin installed but thanks anyway.

    Turns out it was a problem with the theme I’m using, Vistered Little, and a plugin called Skinner. Apparently, something isn’t playing nice with the 2.3 but when I deactivated it everything seems to have gone back to normal.

    I get the whiteout all the time installing bits and pieces. Most of the time itΒ΄s just a php5 error thingie on the server: ALL php code must start with <?php Making a “find and replace” usually does the trick, but in php 5 you also need a space after the <?php start code, this means you have to eye down a few thousand lines of code…
    I hope the code tag stays intact here. Good luck,

    well i had a complete fresh install (test) and i still got the white screen of doom! so…i have no idea what’s going on.

    I had the W.S.D. earlier today while upgrading. I got around it by installing 2.3 files fresh with no plugins (after deactivating them) and no themes. Then I went to the wp-admin/upgrad.php page, which worked it’s magic on my database. Then I reinstalled my themes and plugins from my backup. Now it works like a normal…well, I’m having one issue still, but it’s off topic.

    @ evenglen: I have the same problem. Did you work it out somehow?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘White Screen of Doom!’ is closed to new replies.