WordPress.org

Forums

[resolved] White screen of death - unexpected 'ms_network_cookies' (4 posts)

  1. fregad
    Member
    Posted 1 year ago #

    Hey,

    Urgently need some help.

    My site http://vardagensteater.com/kontakt have white screen of death since a few days. (http://vardagensteater.com currently leads to a index.html to advertise technical problems)

    Apache Error Log says:
    [Mon Jun 09 08:30:37.122858 2014] [fcgid:warn] [pid 951251:tid 140408809699072] [client XXX.XXX.XXX.XXX:XXXXXX] mod_fcgid: stderr: PHP Parse error: syntax error, unexpected 'ms_network_cookies' (T_STRING) in /MYDOMAIN/public_html/nywordpress/wp-settings.php on line 200

    On line 200 in wp-settings.php it says: in ms_network_cookies().

    /**
     * Fires once all must-use and network-activated plugins have loaded.
     *
     * @since 2.8.0
     */
    do_action( 'muplugins_loaded' );
    
    if ( is_multisite() )
    	ms_cookie_constants(  );
    
    in ms_network_cookies().
    // Define constants after multisite is loaded. Cookie-related constants may be overridden
    wp_cookie_constants();
    
    // Define and enforce our SSL constants
    wp_ssl_constants();
    
    // Create common globals.
    require( ABSPATH . WPINC . '/vars.php' );

    What I've tried to solve this:

    • Deactivating ALL plugins and the current theme
    • replaced the folders (including all files) wp-admin and wp-includes from a fresh downloaded copy of WordPress
    • What else to try?

      Thanks in advance and deep bows for your help!
      Fredrik

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try:
    - switching to the default theme automatically by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder and the wp-config.php & root .htaccess files - from a fresh download of your current version of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. fregad
    Member
    Posted 1 year ago #

    Thanks esmi,

    I tried this before (a few times) and it did not work

    - switching to the default theme automatically by renaming your current theme's folder...

    This was new to me... Tried it and no difference.

    - resetting the plugins folder by FTP or phpMyAdmin.

    This I've also tried without success. :(

    - re-uploading all files & folders...

    It's incredibly annoying since the problem seem to be pinpointed to in ms_network_cookies(). in the wp-settings.php. I just can't figure out WHY, and how to fix it?!?!?
    The file is fresh from WordPress. How is it suppose to work?
    Why does it not work when Apache run that line on my site when it does not seem to be plugins nor the theme that is the problem?!?!?
    Is something missing on the back-end server and how could that happen in such case?
    Or is it something in the database that have changed?

    I'm just knowledgeable enough of how it's supposed to work in order to find a solution.

    Please anyone help!

    Thanks in advance!

  4. fregad
    Member
    Posted 1 year ago #

    No more help needed!

    I solved it by rolling back a backup. Now working fine.

    Still incredibly annoyed by the problem though. :)

    Thanks for your help esmi!

Topic Closed

This topic has been closed to new replies.

About this Topic