Support » Plugin: Slider by Soliloquy - Responsive Image Slider for WordPress » White Screen of Death In Admin After Upgrade to Soliloquy 2.5.1.1

  • Resolved linux4me2

    (@linux4me2)


    I attempted to update from Soliloquy 2.5.1 to 2.5.1.1 and got the white screen of death on the admin side. In /wp-admin/error_log, the error was:

    
    [18-Jan-2017 16:54:18 UTC] PHP Fatal error:  Uncaught Error: Class 'Soliloquy' not found in /home/username/public_html/wp-content/plugins/soliloquy-lite/includes/admin/review.php:65
    Stack trace:
    #0 /home/username/public_html/wp-content/plugins/soliloquy-lite/includes/admin/review.php(204): Soliloquy_Review->__construct()
    #1 /home/username/public_html/wp-content/plugins/soliloquy-lite/includes/admin/review.php(212): Soliloquy_Review::get_instance()
    #2 /home/username/public_html/wp-content/plugins/soliloquy-lite/soliloquy-lite.php(169): require('/home/username/...')
    #3 /home/username/public_html/wp-content/plugins/soliloquy-lite/soliloquy-lite.php(144): Soliloquy_Lite->require_admin()
    #4 /home/username/public_html/wp-includes/class-wp-hook.php(298): Soliloquy_Lite->init('')
    #5 /home/username/public_html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array)
    #6 /home/username/public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #7 /home/username/public_html/wp-settings.php(449): do_action('init')
    #8 /home/username/public_html in /home/username/public_html/wp-content/plugins/soliloquy-lite/includes/admin/review.php on line 65
    

    Replacing the Soliloquy files with version 2.5.1 from backup resolved the problem.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same for me. Unable to use the plugin. I get a fatal error message on install of 2.5.1.1.

    #8 /home/username/public_html in /home/username/public_html/wp-content/plugins/soliloquy-lite/includes/admin/review.php on line 65

    error lists as missing ‘Soliloquy’

    • This reply was modified 10 months, 1 week ago by  hockeygal28.
    Bob

    (@boblindner)

    +1 — Here too. I also rolled back to 2.5.1

    Us as well. So far have had 3 white screens in the last hour.

    Me too. Got 500 internal server error until I disabled soliloquy.

    Plugin Author chrisakelley

    (@chrisakelley)

    Hey I just pushed an hotfix to resolve this, I apologize to everyone.

    Cheers, Chris

    abroadnamedpatrice2016

    (@abroadnamedpatrice2016)

    Same thing is happening to me. I’m fairly new to WP so I had to contact my host to fix this for me and now I have a sad header with no scrolling photos. I see that you pushed to resolve this, but I am scared to activate again for fear of another fatal error. Please notify when it’s once again “safe” to Soliloquy.

    I just tried the hot-fix, v. 2.5.1.2, and it works just fine. Don’t be afraid to update your sites with it.

    Same problem here.

    Thank you for speedy the HotFix chrisakelley! And like linux4me2 mentioned – 2.5.1.2 works fine 🙂

    Just in case this helps anyone, here’s what I ended up doing to fix the issue for my client:

    1. Backed everything up (of course)

    2. Using FTP (or cPanel File Manager) renamed the soliloquy-lite folder to soliloquy-lite_BAK

    3. Logged in to WP Dashboard, checked plugins for updates, applied the 2.5.1.2 update.

    Problem solved.

    Kudos Chris! Always nice when a dev publishes a prompt fix, thank you!

    flaggfish

    (@flaggfish)

    I have some websites that updated to WP 4.7.1 in Godaddy Hosting. I updated Soliloquy Lite to 2.5.1.2 and got the white screen (site itself and admin page log in)with error messages that I took screen shots of referring to Soliloquy code issues. I still cannot update Soliloquy. I needed to get Godaddy to deactivate it by ftp since my Admin was broken too. I have some sites that I updated Soliloquy lite on and they are fine. Not sure what the issue is with mine. Any advice?

    Comments seem like 2.5.1.2 is the fix. But not for me.

    hellbertos

    (@hellbertos)

    Thanks @anotherdave

    Like flaggfish, I couldn’t get to the admin panel due to a “fatal error”. Using your technique I was able to get in and get it updated. Now only 8 more sites to go 🙂

    @chrisakelley Thanks for jumping on this and getting a hot fix out there. Much appreciated!

    flaggfish

    (@flaggfish)

    My Godaddy tech had renamed the soliloquy-lite folder as soliloquy-lite2 so I could get my website back. I deactivated the plugin which is version 2.5.1.2

    AnotherDave says he renamed the soliloquy-lite folder as soliloquy-lite_BAK

    Would this fix my problem even though 2.5.1.2 seems to be breaking my site when activated?

    Plugin Author Erica Franz

    (@ericakfranz)

    Hey @flaggfish,

    The folder renaming to ‘soliloquy-lite2’ is the same principle as renaming it to ‘soliloquy-lite_BAK’. 🙂

    It sounds like there may be something else at play on your install. Would you reach out to us through the general contact form at http://enviragallery.com/contact and our support team can further assist.

    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘White Screen of Death In Admin After Upgrade to Soliloquy 2.5.1.1’ is closed to new replies.