[resolved] White Screen of Death After Editing functions.php in Twenty Eleven Theme (15 posts)

  1. skie12
    Posted 3 years ago #


    This is my first time using the support forum, so I hope I'm following the correct protocol.

    I wanted to make the posts on my homepage appear as excerpts with thumbnail images, so I followed the advice here: http://zeaks.org/tutorials/show-excerpts-and-post-thumbnail-twenty-eleven-theme/.

    I'm always reading how you should never edit the parent theme, so I copied the functions.php and content.php files to my child theme directory. There, I changed the code as per Zeaks' instructions and uploaded the files to the server.

    When I went to my blog, http://www.skiedesign.net/blog, I got a white screen of death. The same thing happened when I tried to access my admin panel.

    To undo whatever I had done, I promptly deleted the functions.php and content.php files that I had added to my child theme directory. But my site and admin panel still do not load.

    I then completely removed my child theme directory, to no avail.

    Finally, I downloaded a new version of Twenty Eleven to replace my old (possibly corrupted) one. Even though everything should now be in its virgin state, my site and admin panel still do not load.

    Any ideas? I don't read or write php, and I was nervous about monkeying with those files. I've since read that I should not have copied functions.php to my child theme directory, but I hope the error will not be fatal.

    Many thanks in advance for your assistance.

  2. boh001
    Posted 3 years ago #

    Hi, I've same problem with theme purple-pastel - and I've had the white screen of death 3 times. First 2 I've resolved by re-installing WP all over and re-do my pages... :-(
    This morning I did try to make a minor update to a widget and suddenly after it all went white!
    My hosting provide Surftown.dk uses WP 3.5 and I've asked them if there is something fundamentally wrong since I get into this issue all the time.
    They believe all is in order but reading your mail tell me that at least I'm not the only one with this issue and we are using different themes!

    To avoid future loss of work I would appreciate if someone can tell me how to backup/save my work and how to restore in case same happens again.

    Looking for and hoping for some great responses.
    Rgds. Bo

  3. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    Boh001, posting your issues in someone else's thread isn't helpful to the original poster.

    You can create your own thread for your own issues.

  4. HI skie12,

    Strange... I would have thought that removing the child theme and re-uploading Twenty Eleven would have fixed that.

    You may want to do a manual update and ensure that you updated ALL of the WordPress files and see if that helps.

  5. skie12
    Posted 3 years ago #

    Thanks much, Christine. I completed the manual update, following the instructions very carefully, but I am still left with a white screen both at http://www.skiedesign.net/blog and at http://www.skiedesign.net/blog/wp-login.php?loggedout=true. I realize that even if the methods I tried didn't resolve the issue, the manual update should have. Do you recommend I contact my hosting provider to see if they have a back-up of my files before I made the error? Thanks again.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you checked your site's error logs for clues? Your hosts should be able to assist you with accessing error logs.

  7. skie12
    Posted 3 years ago #

    Hello, Esmi, and thank you. My site's log reported the following error over and over about 7x:

    [24-Jan-2013 20:38:06 UTC] PHP Fatal error:  Cannot redeclare twentyeleven_excerpt_length() in /mnt/stor12-wc2-dfw1/597084/643019/www.skiedesign.net/web/content/blog/wp-content/themes/twentyeleven/functions.php on line 335
    [24-Jan-2013 20:38:19 UTC] PHP Fatal error:  Cannot redeclare twentyeleven_excerpt_length() (previously declared in /mnt/stor12-wc2-dfw1/597084/643019/www.skiedesign.net/web/content/blog/wp-content/themes/twentyeleven_child/functions.php:318) in /mnt/stor12-wc2-dfw1/597084/643019/www.skiedesign.net/web/content/blog/wp-content/themes/twentyeleven/functions.php on line 337

    Just as I suspected, the problem occurred when I tried to edit the functions.php file yesterday afternoon, but I have since restored that file to its original state.

    When I did the manual update, as Christine recommended, I was not able to deactivate the plug-ins as directed because I cannot access my admin panel (and I wasn't sure of another way to do it). The tech at my hosting provider (Laughing Squid) suggested that moving the plug-ins out of wp-content/plugins/ would allow me to at least access my dashboard.

    Thoughts? Thank you again.

  8. dragonsjaw
    Posted 3 years ago #

    Go in through CPanel or however you access your server area and RE-name the plugins folder to Plugins-old or something like that.

  9. skie12
    Posted 3 years ago #

    Hi, dragonsjaw. I renamed the directory "Plugins-OLD," and I still can't access my admin panel. Blog site is still gone too.

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    The problem appears to be in your theme. Re-upload a fresh, unpacked, copy of the twentyeleven folder to wp-content/themes using FTP or whatever file management application your host provides.

  11. Phil
    Posted 3 years ago #

    Yup, upload a fresh functions.php file.

  12. skie12
    Posted 3 years ago #

    Hi, Esmi and Phil. One of the first things I tried (see initial post) was to upload a brand new copy of Twenty Eleven. Following that, I did a manual update of WordPress (as per Christine's suggestion) so I have now "refreshed" my theme twice since I made the error.

    But I will try it again.

    I have just asked my host provider if they have a back-up of my files from before I made the error. If they do, my next step is to upload it to my server and overwrite all the existing WordPress files.

    Thanks, everyone, for your ongoing assistance.

  13. esmi
    Forum Moderator
    Posted 3 years ago #

    Try deleting the old twentyeleven folder before uploading the new copy.

  14. skie12
    Posted 3 years ago #

    Thanks so much, everyone. With your guidance, I located the lingering problem. I use Dreamweaver as my FTP client. Though I thought I had synchronized (more than once) my local files with my remote files, that corrupt fuctions.php file I had created was still hanging out in my twentyeleven_child directory on my remote server.

    I deleted it, and I'm back in business. Thanks again for such responsive support.

  15. skie12
    Posted 3 years ago #

    Marking the issue satisfactorily resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic