WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] White Screen of death

[Resolved] White Screen of death

  • Here lately about 5-7 wp websites I’m supporting have gotten this odd white screen. It happens at all different times, sometimes when you update a page, sometimes when you edit a page, sometimes after you’ve just been logged in for a long period of time and you’re updating. There’s no solid connection between all of these sites. They all use different plugins. This is really killing us at our company trying to support this- any information we can get would be super, really great!!

Viewing 15 replies - 16 through 30 (of 37 total)
  • I always space my functions. I’ve never had a problem. I’d guess that there was something beside a newline that slipped in there– a control character or maybe the wrong kind of line ending (old school Mac line ending used to break things).

    Samuel B
    Participant

    @samboll

    agree with apljdi – can’t reproduce it but glad you got it working

    It had something to do with the functions.php. I removed the blanks between two functions and now it’s working again. So you have to have all your functions after each other?

    Bingo! I was getting the same white screen of death and tried everything in this thread. Removing the white space between the functions worked for me, too. Thank you!

    b00giehead
    Member

    @b00giehead

    My apologies for not having a clear grasp of languages, but I just cured mine this way.

    I opened up the wp-config.php file, and then compared it to my original ‘sample’ version. There was a load of spare text at the top, thousands of letters/numbers. I deleted it all and returned it to how it should look as per ‘sample’ and re uploaded it.

    Problem solved for me.

    I came across the white screen of death right after modifying my theme’s functions.php. I realized that I made a silly coding error — two functions of same name. Fixed it and no more white screen of death.

    After noodling around with all the advice here: disabled plugins and themes… Then looking at the wp-config.php file I added the bit of code defining memory usage. Still no luck. Just a white page when trying to access the site. I renamed the wp-config.php to something else and then removed the “example” on the wp-config-example.php and then suddenly I got the error message saying there was no database file (no surprise). Glimmer of hope here because then I was able to login to the admin panel… I then reset everything back to how it was when I started… (re-named all the folders back to there default names)
    AND…. Now its fine. I host with GO Daddy and their is definately something fishy going on over there. Am I right? I dont fully grasp the problem with the SQL database errors… I am creating a new sql data base through the management tools at GoDaddy… Should I be doing this?

    I’ve had that issue with syntax errors in my functions.php.

    I am building a theme and I am sure it is a syntax issue with my functions.php where i wrote in a custom options panel.
    I get the white page when i save anything: options, posts, pages, etc. Strangely enough, all changes do save, but I have to hit “back” on my browser to get back to the admin panel, and that obviously isn’t acceptable. I can’t find the problem, I’ve checked every bracket, comma, colon, and semi-colon. Nothing seems to be missing or unnecessary (though something must be). Any thoughts? I’d be happy to send someone my code if they are willing to glance over it.

    NonfictionCopy
    Member

    @nonfictioncopy

    Hi,

    I’m getting the white screen whenever i hit ‘Edit’ on a post. The ‘quick edit’ option is fine, and editing pages is fine, but not posts. Tried disabling the plugins and renaming the theme to make sure that it went to the default theme, but that just made my whole site blank – not sure how to edit site after switching to default theme?

    Any suggestions? I’m not overly knowledgable of how everything works, but managed up until now. Hosted through GoDaddy and working in Firefox.

    Cheers, Michael

    @nicolaaas, I was getting this white screen of death everyone is talking about, it was while I was on the options-discussions.php screen where you can set options for comments. After hitting save it was just white screening out…

    After I had a look at my function.php file and removed the spaces between functions like nicolaaas said it somehow fixed it!?!?

    I am running MAMP and testing on Chrome just to let you guys know..

    Thanks nicolaaas

    Steve

    roowilliams
    Member

    @roowilliams

    I was having the same problem after I’d edited functions.php, and like others here, removing spaces between functions worked for me.

    I tried EVERYTHING in this post and of course it was the functions.php file. I just redownloaded the theme and uploaded the original functions.php file.
    Thanks!

    So like the others here, I get the white screen whenever I try to edit functions.php. I figured it had something to do with the spacing, but I’m encouraged to hear I’m not the only one this happens to. It really makes me think that all the emphasis on child themes these days is misplaced: it’s fine for developers, but for us ordinary mortals, give me a simple, old-school theme that I know how to hack without having to touch the g-d functions file!

    I get a white screen when when I check my functions php, When I try to edit my posts I also get a white screen, everything else works fine. If I download my theme again will I loose all my posts?

    James Huff
    Support Team Rep.

    @macmanx

    Rich-r, your posts are safe in your database. Changing your theme will not affect them.

    Please start your own topic if need any more help.

    I had this issue, it was driving me nuts! I solved it by taking white space out of my function file. specifically, it is the white space between php tags.

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘[Resolved] White Screen of death’ is closed to new replies.