WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] White screen of death

[Resolved] White screen of death

  • Host: GoDaddy
    Theme: iFeaturePro by CyberChimps.com
    Website: http://www.ejecucion.com.mx

    I have read many possible answers to this WSoD problem but I am a beginner and I would really appreciate if somebody could describe step by step all the different things to try. I have read: take out plugins, take out spaces on PHP file, increasing the memory, add things to the PHP.ini file, child themes, etc.

    The only thing I have done is to delete 4 plugins I had from the wp admin page and also with FTP the only thing left in my plugin folder is the index file. But still have the problem.

    I made a backup with Filezilla of the wp-content and a backup of my databases in GoDaddy.

    If nothing works, then what?. I am thinking on doing a Theme Restore Defaults and if that doesn´t work then Re install the 3.3.3 wordpress program but before I do that please give some better idea of all this please.

    Thank you very much,
    Claudio

Viewing 15 replies - 1 through 15 (of 27 total)
  • Hi

    In the wp-config.php file, try changing
    define('WP_DEBUG', false);
    to
    define('WP_DEBUG', true);

    That doesn’t solve the problem. But often it starts displaying an error message on the WSoD, which gives clues to what is wrong.

    If you get an error message and need help interpreting it, post it back here. Then someone can then help you.

    Make sure you change WP_DEBUG back to false after the problem is resolved.

    Hi, thanks. I can see my wp-content on the Go Daddy FTP folders but I can´t find the wp-config.
    Also I copied the functions.php file in my notepad and I am deleting all the spaces between tags ><. Now I have a new functions. php file but I don´t know how to change them (I have a backup of this file).
    Thnaks

    wp-config.php is not in the /wp-content/ folder. Sorry, I should have mentioned that. Its in the root folder of the WordPress installation.

    As far as changing the files, rename the existing functions.php file on the server to functions.old.php and upload the new functions.php

    Oh boy, I went through all of the wordpress folder and I can´t find the wp-config
    Sorry, in which folder is it?

    wp-config.php is in the root folder of your WordPress installation. It has to be there because WordPress will not work without it.

    Moderator Jan Dembowski

    @jdembowski

    Volunteer Mod. & Brute Squad

    Or the folder beneath that one, that also works too.

    I found it and I edit it to true. But then since I didn´t know what to do. I just pressed enter a couple of times. Since that might cause a problem I didn´t know what to do and I just got out of the site. Now I am back and it didn´t change the debug. I changed to true. Now, I just close it and it will automatically edit it?

    You are supposed to refresh the webpage now that debug is TRUE to see if the screen then displays an error message. There’s no need to change it back to FALSE until the page starts working. You need to debug the error.

    What is WP_MEMORY_LIMIT set to in the wp-config.php file? (Its possible the line isn’t in there. If not add this line before the WP_DEBUG line
    define('WP_MEMORY_LIMIT', '128M');
    )

    I think I didn´t edit it. I just made the changed to true and then I refreshed the page but the false is still there.

    There is not a WP_MEMORY_LIMIT.

    How do I save my changes to this file?

    I found the way to save it. And I added the WP_MEMORY before the DEBUG.
    What do I do now?

    refresh the page 2 or 3 times

    if you are on windows CTRL + SHIFT + R 2 or 3 times.

    If you still see the white screen and no error message this technique is not going to resolve your issue.

    Using filezilla see if you have a file in any of your WordPress folders, starting at the top one, named error_log or a similar name. If its there it will log the PHP errors that have occurred.

    I did all; I uploaded the new functions.php file with no spaces between tags ><. And the DEBUG and MEMORY are there now.

    I refreshed the page several times, but no error message. In the Filezilla I could not find an error log either.

    Would I have to restore the default in my theme?

    I suggest you temporarily switch to the twenty ten or twenty eleven theme and see if it works then. If it does its a problem with your normal theme. if it doesn’t its something not related to the theme.

    I also change the MEMORY to the:
    define('WP_MEMORY_LIMIT', '128M');
    )
    But still the same problem.

    OK I changed to the twenty eleven and there the new post in the blog works fine.

    Well, now you know that the problem is in your theme. Now you have to eliminate things one by one until you determine what is causing the problem.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] White screen of death’ is closed to new replies.