Support » Plugin: Better Font Awesome » White screen of death

  • Resolved Handstand

    (@handstand)


    I just updated my version of the plugin to the latest version and it’s giving me the white screen of death. When I deactivate it, everything goes back to normal. Is there a way to go back a version of the plugin? It was working perfectly before. Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • I got it as well. It is looking for:

    private function load_depenencies() {
    require __DIR__ . ‘/vendor/autoload.php’;

    Here are the errors:

    Warning: require(/usr/www/users/xxxxx/xxxx/wp2/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/vendor/autoload.php): failed to open stream: No such file or directory in /usr/www/users/xxx/xxx/wp2/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/better-font-awesome-library.php on line 327

    Fatal error: require(): Failed opening required ‘/usr/www/users/xxx/xxx/wp2/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/vendor/autoload.php’ (include_path=’.:/usr/local/lib/php’) in /usr/www/users/xxx/xxx/wp2/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/better-font-awesome-library.php on line 327

    Same too, getting Error 500 after the updated. Reverted back to previous version.

    Were is the previous version kept?

    goto this url -> https://wordpress.org/plugins/better-font-awesome/advanced/

    scroll down to bottom and you can select the version to download.

    Thanks for the link. I installed the 1.71 version and it worked fine. I appreciate the help.

    Thanks (@loominosstudio)!!!

    Thanks @loominosstudio and @caltuna123 for the confirm.

    Just did the same – 2.0.0-beta is definately broken, re-installing 1.7.1 worked like a charm.

    😀

    Can I just confirm…The last version is broken.

    Same here. Error log

    [09-Apr-2018 03:54:44 UTC] PHP Warning:  require(/xxx/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/vendor/autoload.php): failed to open stream: No such file or directory in xxx/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/better-font-awesome-library.php on line 327
    [09-Apr-2018 03:54:44 UTC] PHP Fatal error:  require(): Failed opening required '/xxx/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/vendor/autoload.php' (include_path='.:/opt/alt/php70/usr/share/pear') in xxx/wp-content/plugins/better-font-awesome/vendor/mickey-kay/better-font-awesome-library/better-font-awesome-library.php on line 327
    Plugin Author Mickey Kay

    (@mcguive7)

    My apologies all. This update was not meant to be pushed. I’m reverting the active version momentarily. Please disable the plugin and revert back to version 1.7.1. My sincere apologies for this error.

    Hello!

    I deleted the plugin from my hosting service after receiving this error and installed the version 1.7, but I’m still getting the white screen of death. Could you help me?

    Did you actually delete the plugin from the site and run the site without it? Do you have caching turned on? (Some ISPs install a caching plugin… I hate caching!) Can you get to the site via FTP or your ISPs file manager to look at the plugin directory?

    Plugin Author Mickey Kay

    (@mcguive7)

    Hmmm, this should definitely not be happening aehernandez. As Caltuna123 mentioned, this sounds like an unrelated issue. Restoring BFA 1.7 should’ve fixed this issue, since it was only the latest beta version that caused problems. Happy to help in whatever way I can if this persists.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘White screen of death’ is closed to new replies.