Support » Plugin: Elementor Page Builder » White Screen – Can’t Edit

  • Resolved emrekumas

    (@emrekumas)


    Hi,

    I’m using Elementor for about one months without any problem. But since this morning I can’t edit a page with elementor. It opens a white page and stops loading. I have tried all the solutions I’ve found on the net but none of them worked. I was suspicious about plugin conflict because yesterday there was an update but disabling all plugins didn’t solve it too. I’m using the Phlox theme. Please, if anyone can help, I will be very grateful.

    Here is the System Info: https://pastebin.com/xUYNZehs

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hello, this is exactly my problem. Can’t work any longer. At least the front end is not broken, but I can’t use Elementor for my designs at the moment. And I don’t dare to go back to a previous version, as I have to do that on a productive site.

    Hope there is a fix coming soon?

    Klaus

    White screen seems to be a very common problem with Elementor. Have you checked your PHP memory and also the version of PHP your using. These can be found in the System area of Elementor. Memory should be 256 minimum ad PHP level preferably 7+.

    It seems Themes have are a big part of this. I used OceanWP and have had no issues since I update the above changes.

    I increased the memory to 256 but nothing changed, also today there was an update to Elementor but nothing has changed. I checked the PHP version it is 5.6 should I update it to 7+? Do you think it will solve the problem?

    Hi,

    Yes, you should indeed update to php 7+ and check at your host, what is your max allowed memory. Older php is the main cause of white screens of not being able to edit with Elementor.

    If they set that to lets say 64, then you can change it all you want it wont go any higher…

    Please make sure you meet all these:
    https://docs.elementor.com/article/38-requirements

    Well, I changed PHP version to 7.2.1 but still the same problem. Also the maximum memory is 256 so I don’t think its the cause. 🙁

    OK you have cleared all cache, if on a cdn there too?
    Changed theme?
    De-activated all plugins?

    PLease read and provide what is asked for in this forum:
    https://wordpress.org/support/topic/please-read-before-you-post-an-issue/

    • This reply was modified 1 year, 4 months ago by LesTexas60.

    Hi again,

    thanks for your support. And yes, I have cleared all cache, changed theme and de-activated all plugins but none of them solved the issue. The problem is still present. Thanks again.

    Hmmm, not sure what to suggest next to be honest.
    You also tried this?:
    https://docs.elementor.com/article/184-cant-edit-with-elementor

    When you cleared all possible cache, did you follow this order:

    Disable all plugins and switch theme to twenty seventeen or OceanWP.
    After all that clear all possible cache.

    Issue was still present?

    Do you have this on every page or just one or some of the pages?
    It did not happen before you did the updates?
    If not, which plugins were updated and what happens if you get back to their previous version?

    If not have you reverted back to a previous backup ( if you have made backups? )
    I recommend you do so or start doing so. Personally love All in one migration.

    PS. love what you have done with the site!

    Oh, one more thing that comes to my mind…
    You did increase you memory in your wp-config.php right?

    But what is the max permitted at your host?
    If they have a lower limit set, you can change whatever you want in wp-config it wont work.

    I have tried the link you mentioned already, it did not fix.

    I also tried what you suggested step by step but that didn’t work either.
    The issue is on all pages and yes it didn’t exist before updates.

    I’m so regretful that I didn’t take a backup before so I guess I need to restart again 🙁

    Thanks for your help again.

    Hi,

    True, please take a backup right now haha!

    But you may not need to start it all over again.
    Just download the previous versions of those recently updated plugins and replace them with the updated ones. That just might do the trick for now.

    If so, take anohter back up again ( you can not have enough of them, learned it the hard way myself ) and ask the developer(s) of that plugin, for help to make it compatible.

    You can roll back to a previous version with a plugin like this one:
    https://nl.wordpress.org/plugins/wp-rollback/

    Or, if you are comfortable with ftp, you can just upload the previous version tot the wp-content>plugins folder and overwrite the newer version.

    These links might be helpfull:
    https://kinsta.com/knowledgebase/download-older-versions-of-wordpress-plugins/

    You might also try to roll back the Elementor plugin itself.
    As they have it build in, that’s the easiest one.
    You can read up about that feature here:
    https://docs.elementor.com/article/382-rolling-back-to-a-previous-version-of-elementor

    It would not be the first time by the way, that doing the above, and then do the update again, cleares the problem all together.

    Hope this helps, let me know if it worked!

    I don’t know how I got into this trouble, rolling back plugins and themes didn’t work either. Now it seems to me that it is unsolvable. Thanks for all your support but this is something very bad xD 🙁

    This is very strange indeed.

    I would suggest, if you start over, to first take a backup of what you have now.
    Then remove all files and install a fresh WordPress.

    The choise is yours, but I am a big fan of the free OceanWP theme.
    Why not give it a try if you need to start over anyway?

    As you created your pages with Elementor, you can save each page as a template and export it ( before deleting the old site ).

    In the complete fresh install, import the saved templates, that should save a lot of hard work. You will need to set some settings in customizer for the OceanWP theme, but you can easely reproduce your current look with this theme + Elementor.

    As soon as you have the fresh clean install, try right there and then, if the issue is gone, before doing more work.

    Good luck, its a shame because the site does look very nice!

    I see, by the way, that someone posted this issue with your current theme and Elementor: https://wordpress.org/support/topic/may-15-update-created-broken-pages/

    When you switched themes, what theme did you switch too?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘White Screen – Can’t Edit’ is closed to new replies.