W3 Total Cache
[resolved] White Screen, Cannot Login Admin, Theme Directory Missing W3 Total Cache (5 posts)

  1. thebiganswer
    Posted 4 years ago #

    At some stage over the weekend W3 Total Cache developed an error and as a result (as far as I understand) my Web site was returning the 'white screen of death', and I was unable to log in to the admin section.

    If it helps anyone else, here's what I did to resolve the issue:

    1) FTP to your Web server.
    2) Find the 'wp-content' folder.
    3) Find the following files in that folder: object-cache.php, db.php, and advanced-cache.php.
    4) Rename them by adding something like ".temp" to the end, e.g. "db.php.temp".
    5) This should enable you to load your admin login page.
    6) Once logged in, you can then try to remove the ".temp" characters from the file names. You may then need to disable or re-enable the W3 Total Cache plugin.
    7) There may or may not be a message from WordPress regarding one or more plugins which requires some kind of action. If so, see below...

    Now, I should point out a few things:

    1) You may find you are able to log into your admin section in some browsers but not others. This may relate to the Cookie Domain setting in W3 Total Cache (for more information please use Google). Basically, commenting out the Cookie Domain setting in your wp-config file may be a temporary solution (please read about and understand the issue before making any modifications to your wp-config file).

    2) Once you are logged into your admin section (whether straight away, or after changing the W3TC file names mentioned earlier), you may see the message, "ERROR: The themes directory is either empty or doesn't exist. Please check your installation." This was a worrying message to see - my first thought was, "has someone hacked in and deleted the theme and possibly the wp-content folder?" However, after checking via FTP my fears were unfounded and the message was something of a red herring. I then checked the permissions code on the wp-content folder and they were "744"; this setting was wrong and should have been "755" (i.e. allow public/group to execute but not write). To provide some content, in the W3TC settings section it prompts the user to change permissions back to "755" (where necessary) after making settings changes, so perhaps I had mis-configured the permissions.

    I mentioned earlier that you may be able to log into the admin section in some browsers; well, if you were able to log in but the plugins page was giving an error such as, "W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove such/and/such/a/file.php" then renaming those files may do the trick.

    Finally, WordPress did fall over a bit and disabled all active plugins, so I had to re-enable the desired ones. After that I was back to normal.

    In conclusion, if you see the white screen and/or you cannot log into your admin section (and if you are running W3TC, but not necessarily) then consider the following (in no particular order, though in retrospect the permission setting may be key):

    1) Ensure the wp-content folder has the correct permission setting.
    2) Check the Cookie Domain setting.
    3) Rename W3TC files in wp-content folder (remember to revert afterwards).
    4) Check that your theme and the wp-content folder do exist (!)

    I'm sorry if the instructions are hard to follow or seem to jump about; I was busy trying everything I could think of as quickly as possibly to resolve the issue so I pieced together what I could. In fairness to the fantastic W3 Total Cache plugin, it could well be that the folder permission issue was the key to the whole thing. However, I'm a little concerned that the Web site was fine when I left it, but only hours later (without human intervention, I believe) it had developed a fault, and the symptoms did point to W3TC.

    I hope [some of] this will be of use to someone else.


  2. Frederick Townes
    Plugin Author

    Posted 3 years ago #

    What were the errors in the web server log? Remove the W3TC rules from .htaccess and rename the plugin's directory name.

  3. WebEndev
    Posted 3 years ago #


    I had the same thing happen, and your post was invaluable in getting my site back up and running.


  4. Julian Luo
    Posted 3 years ago #

    I am having the same problem since two days ago.
    I installed this plugin on 5 of my wordpress sites, but only one has the problem. And this is the only one that has two subdomains pointing to the same site. Could this be the problem?
    I tried to rename the directory of the plugin, and renamed all other related files in the wp-content folder, it worked last night. But today it is not working that way. The only difference is that last night I renamed the files in wp-content as suggested by the error message, one by one. Today I just renamed them all, not one by one, and it is not working.
    I am goingto remove the W3TC rules form .htacess now and see what happens.

  5. Julian Luo
    Posted 3 years ago #

    I just renamed the directory and removed the rules from W3TC. It's not working. I disabled all the active plugins from the database wp-options table, not working.
    I used Internet Explorer, instead keep trying on Firefox, it worked. Just like yesterday, Internet Explorer which I rarely use, brought me in. How strange!
    After I made everything back to it's original sttus using Internet Explorer, still Firefox shows nothing, not responsive.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic