WordPress.org

Forums

[resolved] [closed] White screen after manual update to 3.4.1 (13 posts)

  1. mknightjr
    Member
    Posted 2 years ago #

    I manually updated my site to WP 3.4.1 a few days ago and I now have the "white screen of death". None of the pages fully load. Instead, a zero (0) appears in the top left of the each page.

    I have searched through the forum for tips on how to resolve this issue, and I have tried just about everything that was recommended. I have deleted the wp-admin and wp-includes directories and replaced them with new ones (downloaded from WP). I have also done the same for the wp root directory files. I've even deleted my content folder and replaced it with a new one (downloaded from WP).

    Nothing has worked so far.

    Any ideas on what's going wrong here? Help!!!

  2. govpatel
    Member
    Posted 2 years ago #

    The only way to find out what is causing a problem is check server error log.

    If you can not find from there try

    First check if you do not have have any blank space before <?php
    in wp-config.php if there is none then try and add this code in next line

    error_reporting(E_ALL); ini_set('display_errors', 1);

    In addition, add the following code above (if you do not have the debug line)
    /* That's all, stop editing! Happy blogging. */ :
    define( 'WP_DEBUG', true);

    See what error you get.

    once you found the error replace the file and delete the line you added and change true to false

  3. mknightjr
    Member
    Posted 2 years ago #

    Thanks so much for your help, govpatel!

    Following your suggestion, I inserted the code below into the wp-config.php file.

    error_reporting(E_ALL); ini_set('display_errors', 1);

    After refreshing my site I received an error message that said there was an error in the wp-config.php file.

    Parse error in ...mywebsite/mywebfolder/wp-includes/option.php on line 225

    I did some research on this error and found that it was related to my host using an incompatible version of php...apparently, WP 3.4.1 must run on PHP 5.2.4 or higher. My host was set to PHP 4. I went into the control panel on my host and changed my PHP setting...and that fixed the problem. I was able to run the upgrade and my site now loads!

    Thanks!

  4. govpatel
    Member
    Posted 2 years ago #

    You are welcome

  5. AllureSenses
    Member
    Posted 2 years ago #

    Hi Govpatel!

    I've tried all of the above mentioned and it hasnt worked for me :(
    I am evening running on PHP 5. There is no error message just white screen. I get the wp-admin from a saved link but it will show up if I type it in the browser.

    I dont know what else to do

  6. govpatel
    Member
    Posted 2 years ago #

    It should show the error if you followed and have debug true in your wp-config.php file.

  7. AllureSenses
    Member
    Posted 2 years ago #

    Where do you put the debug true? Above the "error reporting" or above the <?php ? or below the "error reporting"?

  8. AllureSenses
    Member
    Posted 2 years ago #

    Ok... I tried in all 3 ways that I asked. And no error message. Just white screen

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - running the upgrade manually via wp-admin/upgrade.php

  10. AllureSenses
    Member
    Posted 2 years ago #

    It worked!!!
    Thank you Esmi!!!

  11. JMatt578
    Member
    Posted 2 years ago #

    @esmi... I have tried all those except I don't know how to run the upgrade manually. Also nothing changes when I reset the plugins or try to switch themes.

    The error message I repeatedly get is:

    [13-Aug-2012 18:52:18 UTC] PHP Fatal error: Call to undefined function wp_load_translations_early() in public_html/wp-includes/functions.php on line 1129

    I'm really unsure as to what to do, I can't log into the wp-admin. Time/date of the website has frozen on the front too.

  12. govpatel
    Member
    Posted 2 years ago #

    You need to start your topic so that you get help

  13. JMatt578
    Member
    Posted 2 years ago #

    I did, no one is responding to it:

    my topic

Topic Closed

This topic has been closed to new replies.

About this Topic